Can’t Display PDF’s Because Of Overlay App (Grammarly, textexpander)

Steps to reproduce

Step 1:
Open a file in Obsidian with a link to a pdf file.
Example: ![[example.pdf]]
Now you can see the pdf content. Great.

Step 2: Install Grammarly App and open it.
Grammarly now tries to integrate in all apps in the desktop and that is causing Obsidian to not show the pdfs content.

Disable (exit) the Grammarly App and reload Obsidian.

Expected result

Work as normal

Actual result


Windows 11

Additional information

Thanks. You should open a bug report to Grammarly.

HI. this is my first bug-report. pardon me for any mistakes.

PDF’s are not displaying in obsidian reading view. it just shows up as grey blank screen. I posted in obsidian forum and discord, I was suggested to post it as a Bug-report. I am attaching the link to the video recording. please check. (in the recording minimal theme is installed, its not working for any theme).

What all I tried:

  1. Updated Obsidian
  2. Uninstalled and reinstalled with new downloaded latest version from website.
  3. removed plugins
  4. turned on safe mode
  5. changed to default theme
  6. and finally, I reset the Windows 11. Issue is still persisting.

My PC Configuration:
i7, 3080RTX, 32gb ram

Link of the recording: Loom | Free Screen & Video Recording Software

Link of the Obsidian forum post: Can't Display PDF's - #2 by joethei


Can you please:
0. Command Palette → Copy debug info. Paste the result here.


  1. Enter safe mode
  2. Use the default theme
  3. Restart obsidian
  4. Do a screen recording of this happening

Also, can you link/attach a copy of PDF where this is happening?

Where is your vault stored exactly?


Here is the recording: Loom | Free Screen & Video Recording Software

Vault is located in D:\ObsidianMDD and i have synced it.

Its happening with all pdf. this is the recent one i tried: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Debug Info:
Obsidian version: v0.14.6
Installer version: v0.14.6
Operating system: Windows 10 Pro 10.0.22000
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: on
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: off
Plugins installed: 21
Plugins enabled: 20
1: Calendar
2: Workspaces Plus
3: Various Complements
4: Timeline
5: Theme Picker
6: Recent Files
7: Podcast Note
8: Media Extended
9: Map View
10: Living Graph
11: Kindle Highlights
12: Kanban
13: Highlightr
14: Excel to Markdown Table
15: Banners
16: Advanced Tables
17: Activity History
18: File Explorer Note Count
19: Minimal Theme Settings
20: Contextual Typography

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

if you press ctrl-shift-it, do you see any errors in the console that appears?

Does this happen in the sandbox vault

Click on the ? icon lower left corner → Open sandbox vault.

yes. it happens in sandbox vault also. and i am not sure which errors. i have attached a screenshot.

console is the second tab in the first screnshot.

Out of curiosity, does that PDF work in chrome?

Oh here it is. and yes. all the pdf’s open in Brave, Chrome, Acrobat DC, etc. even the pdf files which are in vault (previously stored)

ok, thanks for proving all the info. It’s likely an electron problem but we’ll look into it.

Thank you!

i am a Researcher. i read and make notes of research in obsidian. i will wait for a solution. thank you again :pray:

There will be a new public release likely next week. Please download and reinstall obsidian when it happens and let me know if you still have this issue.

1 Like

Ok. will do.

do you use grammarly?

no. i dont use it in this pc.

I saw the other Post on Grammarly. i checked all the apps i have installed. surprisingly not many as i reinstalled windows recently.

It appears that the Text Expander application is the source of problem here. when I exit text expander (from the system tray) and start obsidian, Pdf files function normally. if i open text expander app while obsidian is running, The pdfs then return to being blank grey. However, the unfortunate fact is that I purchased a text expander membership in order to use it in conjunction with Obsidian. They don’t seem to be working. :frowning: this is the Text expander version i have.
Screenshot 2022-06-04 204558


I use espanso (free) and it works great. Send a BR to them.

I’m having the same issue with several of my PDFs. For me, it’s because of Grammarly. Once I quit Grammarly (not just disable it), I’m able to view all PDF pages in Obsidian. However, I am able to view page thumbnails with Grammarly activated.

I use Obsidian and Grammarly as a combo for super notetaking & writing. I’ll wait till the next update to see if it gets fixed, otherwise, I’ll also message Grammarly. Thanks!

1 Like

I am having this issue as well

Windows 10 pro with latest textexpander

are there any updates on this? I know its tagged as an ‘upsteam problem’ but it is affecting my workflow - there must be other users affected