Can't apply Inter as a custom font

Hi,

I am not sure if this is me needing help or a possible bug, but after the upgrade to 0.15.6 automatic transformations of a - and > together to an arrow → stopped working. I believe this is because the the font changed from Inter to the system font which doesn’t support this (in my case the font is San Francisco).

On the forums it was suggested to install Inter if we preferred that font. So I installed Inter in my font book and it’s available in other apps. However It does not show up in the appearance font drop down in Obsidian.

I downgraded to 0.14.15 and it the arrows work again, and weirdly I can set the font to Inter in my appearance preferences.

Any ideas?

I am on MacOS Monterey 12.4

What I’m trying to do

1 Like

Just type Inter and press Add.

Don’t pay attention to the red exclamation mark after typing in the input field.

This doesn’t work. While the UI looks like you are adding Inter it does not get applied in the system unless it’s a font in the list. If I follow your instructions, save my preferences, and then open them again Inter is no longer applied.

I can’t apply any font (and have it work) unless it’s in the dropdown list. And Inter is not one of the options.

Sorry @acjacobson, that worked for me so just shared with you. I’ve seen it in several other forum answers:

But, maybe you case is a particular one. Hope you find someone with an alternative or answer that suits you.

1 Like