Can't access existing vault when setting up Obsidian on ios

I have installed Obsidian on my Mac and set up a vault in iCloud. That’s working fine.

Now I’ve installed Obsidian on my iPhone and would like to access the same vault. That’s not an option in the initial setup. It looks like this problem has previously been reported, and one workaround has been mentioned, but that is not working for me.

1 Like

What did you try, and what happened?

@CawlinTeffid Sorry for the delay in responding, just saw your reply.

  • I tried opening the Obsidian app on my phone. The opening screen shows me 2 options:

    • Setup Obsidian Sync
    • Create new vault

    I don’t want to do either of those

  • I also tried using the Files app on my iPhone and using that to force an existing MD file from my existing vault to open in the Obsidian app in order to “prime” the app, as suggested in an existing thread on this problem. This takes me to the same opening screen described above.

Maybe this will help:

  1. In Files, open the iCloud > Obsidian folder.
  2. Long-press the vault folder you want, and choose “Download now”. The folder size will be replaced by download progress info until everything is downloaded. All the files in the folder should now not have cloud icons on them.
  3. Close Obsidian (swipe it away in the app switcher), reopen it, and try again.