Can no longer search for full URLs that start with https:

Steps to reproduce

  1. Search for a full URL that starts with https://, e.g. https://www.google.com
  2. Enable “Explain search terms”
  3. Now it says “Operator ‘https’ not recognized”

Did you follow the troubleshooting guide? [Y/N]

Yes

Expected result

Expected to see a result for the search query. This was how it worked before the latest update.

Actual result

Environment

SYSTEM INFO:
Obsidian version: v1.4.5
Installer version: v1.2.8
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:52 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T8103 22.6.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 12
Plugins enabled: 12
1: Advanced URI v1.38.1
2: Style Settings v1.0.6
3: QuickAdd v1.2.1
4: Natural Language Dates v0.6.1
5: Sortable v0.3.1
6: Commander v0.5.0
7: Tag Wrangler v0.5.11
8: Templater v1.16.0
9: Dataview v0.5.56
10: Minimal Theme Settings v7.2.2
11: Tracker v1.10.9
12: Metadata Menu v0.5.2


Additional information

For context, I create my newsletter using Obsidian, and searching for existing mentions of URLs is crucial in my process.

CleanShot 2023-09-02 at 13.01.27

1 Like

Put the url within quotes "https:\\xyz" and see this

That does work, but it takes 4 extra steps. My workflow is as follows using VIM mode.

Previously:

  1. Select the link using v-i-(
  2. CMD + SHIFT + F

Current release:
3. Hit the left arrow
4. Type "
5. Hold CMD + right arrow
6. Type "

Thanks!

By all respect but i too think this bug report isn’t sufficiently “solved”, adding workarounds like " or \ to make searches work, is unintuitive, not user friendly.

The task of computers and apps is to improve the state of flow and compute repetitive tasks as well as solve technical gaps not related to our daily work.

2 Likes

I have a similar problem and the proposed solution looks pretty bad.

This change intentional and was made to accommodate the properties search and refactor the search box parser. If using quotation marks is unsatisfactory, feel free to open a Feature Request with alternative proposal.

This is a regression. It doesn’t make sense to break a feature so another half-baked/poorly thought out feature can be implemented. This is worst than not having an UI for the frontmatter (Properties is basically this).

This obviously is a bug, even when it doesn’t find anything it still shows “2 results” and even an error in the console.

Search should be intuitive, adding extra steps that weren’t necessary before is really backwards.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.