Bullet point syntax gets captured by auto-pair assistance

(searched for “astersisk” and “bullet” to avoid dupes, didn’t see this reported)

Steps to reproduce

  1. “auto pair” setting on (the default)
  2. type * (asterisk space) as though to begin a bulleted list.

Expected result

Editor contains only * , ready to type a bullet list entry

Actual result

Editor contains * *, thinking I wish to add italics.

Environment

  • Operating system: n/a, I should think

  • Obsidian version: 0.64

  • Using custom CSS: no


Additional information

Auto pair quotes is a feature some people like, but if they can’t interop with bullet points, I think folks will have to turn the setting off.

Maybe a good solution is to exclude .\s\*\s for the purposes of autopairing * (and maybe -, I didn’t try that one)

Same issue is still happening on v0.8.9

This is not an issue. If you don’t want autopair for * and _ just disable it in the options.

@simplgy you original bug report is more a feature request. That is, do not autopain if * is the first character of a newline. I am not sure it is a good idea (Afterall, I may want to have the first word bold). Anyway, if you are still interested, open a feature request.

How do you disable in the options?

Editor → Auto pair Markdown syntax