[BUG] vim mode Ctrl-d navigation is broken

Steps to reproduce

  • Turn on vim edit mode
  • Try to Jump forward (down) a half screen using Control-d

Expected result

I expect to navigate forward (down) half a screen.

Actual result

The character under the cursor is deleted.

Environment

  • Operating system: macOS
  • Debug info:

SYSTEM INFO:
Obsidian version: v0.15.2
Installer version: v0.13.31
Operating system: Darwin Kernel Version 21.4.0: Fri Mar 18 00:45:05 PDT 2022; root:xnu-8020.101.4~15/RELEASE_X86_64 21.4.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: LYT Mode
Snippets enabled: 0
Safe mode: off
Plugins installed: 31
Plugins enabled: 26
1: Vimrc Support
2: Various Complements
3: Templater
4: Tag Wrangler
5: QuickAdd
6: Obsidian Link Converter
7: Advanced Tables
8: Calendar
9: Dataview
10: Emoji Shortcodes
11: Excalidraw
12: Hotkey Helper
13: Natural Language Dates
14: Pane Relief
15: Native Scrollbars
16: Minimal Theme Settings
17: Hider
18: Relativenumber (relative line numbers)
19: Kanban
20: Remember cursor position
21: JiraIssue
22: Hotkeys for specific files
23: Better CodeBlock
24: Editor Syntax Highlight
25: Obsidian42 - BRAT
26: Query Control

RECOMMENDATIONS:
Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

will be fixed 0.15.3

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

On mac is cmd-d.