[Bug] Can't write to SD card (external storage)

sorry to hear that.

I’m having the same problem creating a vault on a SD card on a Samsung Galaxy 7/Android 8 and Obsidian 1.0.4 – no problem on local storage.

I solved my problem (just above) by using Autosync for OneDrive to sync a laptop backup to my phone’s sd card, then just opening the folder as a vault. Obsidian Sync might allow the same thing.

I very much appreciate the mobile version, BTW.

Same problem here, V1.0.4. Samsung Galaxy Tab S2 / Android 7.0.

Thank you. It’s really working.

I also can’t open a vault from USB Drive (external SSD) on android 11 (Samsung OneUI). When I select the folder for the vault, it says: "Error: This path cannot be resolved: content://com.android.externalstorage.documents/tree/ … "
It works for me to create and edit in vault locally, but it defeats the purpose of having all my vaults on the external SSD. Can anybody help? Or is it a bug that needs fixing?
Edit: Obsidian version 1.0.4

1 Like

Google recently introduced new security policies in Android to protect SD cards by restricting apps from writing to certain directories. It’s really frustrating.


Same problem here on Android 7 - Obsidian v1.0.4
Can create on internal storage but not on SD card in any folder.

Would appreciate some help! Thanks!

I have the same issue with my Samsung galaxy tab S6 lite and a vault in an external SSD.

1 Like

It’s working now. Maybe it’ll help us to solve the bug.

I am still having the same problem. Can you please give a bit of direction to open a vault in an external SSD with the obsidian mobile app, please? Thanks. I am on a s tab. Android 11.

1 Like

Looking at the error message when trying to create a new vault on an SDCard (obsidian 1.0.5, Android 10)

Path I was trying to use was /storage/22E7-0E12/Documents while the error mesasge was

The part of the path has been appended to the end of the path in the error message. Also, character %3A is the : character, not sure why that character is being used midway through a directory path.

Could that be why permissions aren’t working, the path Obsidian is requesting permissions for doesn’t exist.


I’m having this same issue in my Samsung tab s6 lite, running Android 11 & Obsidian 1.0.5

Has anyone gotten this resolved or did everyone just kinda give up and avoid doing it?


I am unable to put obsidian on my SD Card. It’s giving the following error:

“Failed to create vault. Unable to create directory, unknown reason”.

Is there someone working on this bug?


[ ] iOS
[x] Android

Obsidian Mobile version: v1.0.5

I have an obsidian vault in an external SSD. I use it on my computer. I can connect the SSD to my tab and view the attachments and pdfs in the vault.

I recently tried to use the “open folder as vault” feature on the mobile app. I was trying to open the vault in my external SSD. But the mobile app only accepts the documents folder in internal storage. But when I chose the vault from the external drive to open with obsidian app, the app shows an error massage.

Are you “hiding” the file/folder names on the view of the SSD, or are you actually using emojis as folder and volume names?

If you are using emojis as names, then odds are good that’s your problem; Its likely that Obsidian Mobile is expecting a more “standard” file/directory structure, with regular text names for volumes and folders. Perhaps try that and see if the issue resolves?

I am using emojis as my vault name. :sweat_smile:

I tried to change the vault names to words. But the same error message is still showing. Still can’t open the vault.

1 Like

For anyone who still has problem with saving external storage. I need you to tell me these things.

  • Obsidian version
  • Android version
  • Type of external storage: microsd card? external usb drive?
  • what error do you get?
  • A screenshot of the error. If there is a path in the error, make you the screenshot includes the path.
1 Like
1 Like
  • Obsidian version: 1.1.0
  • Android version: 10
  • Type of external storage: microsd card? external usb drive?: micro SD card
  • what error do you get?: “Failed to create vault. Unable to create directory, unknown reason.”
  • A screenshot of the error. If there is a path in the error, make you the screenshot includes the path.:

Extremely annoying. The very reason I wanted to switch to Obsidian was to use it offline on mobile, but I can’t even create the basic vault for “unknown reasons”.