[Bug] Can't write to SD card (external storage)


[x] Android

Obsidian Mobile version: v1.0.2
Android version: 6 (kernel version: 3.18.19)

The mobile app can’t create a vault on SD card (formatted as external storage). Screenshots: root dir, subdir. When I select the internal storage, it works fine.

I also tried to use my existing vault, synced via Dropbox to SD card: it loads fine, it can read the files but cannot write them or create new files, it shows FILE_NOTCREATED error.


Having the same problem with my USB stick and tablet. File_NotCreated error when I try to edit.

1 Like

Please add [Bug] or [Feature] to your post title, then delete this line.


[ ] iOS
[x] Android

Obsidian Mobile version: v1.0.2

I’ve tried setting my vault to my usb, but it won’t let me. It keeps popping up with a message saying ‘Error: this path cannot be resolved.’ Just wondering if anyone has found a way around it and could let me know. Much appreciated.

1 Like

Does obsidian have permission to accesse the external storage?

Storage permission is turned on: screenshot
There is no other option for external storage (at least on my Android 6 phone).


Similar issue on A9. Obsidian 1.0.3.

App has SD permission. Even runs from SD card.

1 Like

Same issue here. When I try to create a vault on external SD card/storage, I get “failed to create vault. Unable to create directory, unknown reason.” Similar message when trying to use an existing empty folder on external storage.

It does allow me to create my vault in the Documents folder on main (built-in) storage, though. (Which is the workaround I’m using for now, although not ideal.) But not in the root folder of main storage.

Using Android 8.0 on Samsung Galaxy S7, Obsidian Mobile v1.0.3. Screenshots attached showing Obsidian does have all storage permissions that I’m able to see to give it, and system info. Also reports that Obsidian has “access to 5 folders/files” next to the listing for “External Storage”, but no way that I know of to tell which folders those are.

Also of note, the file picker dialog shows “allow write permission” at the top of its popup left bar menu when picking a location to place the vault folder.

PS, very grateful to the developers for making this available on mobile now as well as desktop; it works amazingly well and better than expected, even on my older devices (except, notably, when using iCloud as sync provider on iOS, (on iPhone 6s/iOS 13), app becomes practically unusable due to slowness, lags, hanging. But I switched to using Obsidian Sync, and everything works quite smoothly. Somehow iCloud sync slows things way down. :thinking::slightly_frowning_face:)

So far, so good on Android with Obsidian Sync on this somewhat older device.

(Sorry to digress off topic, but wanted to share that I’m case it’s useful to someone else while I’m here, in case I don’t get around to posting it separately.)

1 Like

I have the same issue with my Samsung Galaxy A8 (A530)
Internal storage works fine, but cannot write to SD-card even though as far as I can tell app-permissions are OK.

Obsidian 1.0.3
Android 9 (last update May 2021)
Kernel 4.4.111

I also have this issue. The app has the necessary permissions, but can only read from my vault on the sd-card, when I make an edit to a file i get the FILE_NOTCREATED error.

Obsidian Mobile version: v1.0.2
Android version: 9 (kernel version: 4.9.148), huawei device

1 Like

I also have this issue with my Asus Zenfone5z whether in internal storage or sd card.
When I try to create a new vault in my interal storage, I got “Failed to convert path.”

I’m using Android 10.0 and Obsidian version is 1.0.3.

Go to your file manager and create in Android/data path a folder called md.obsidian (works for internal storage and sd card). Choose that one as a vault in Obsidian app, it worked for me. I hope I can help you.


Hello, I am afraid here we are conflating several bugs. Have you attempted to create a new vault in a subdirectory of SD card. Like you create the directory obsidian Obsidian and then create a vault under it. Does it work if you do so?

If you are insider, you please check build 1.04, we added some fixes for these issue. I am not sure it will work for everyone because I am not sure everyone has the same problem.

This also does not work. I tried SD-card root, subfolder and sub-subfolder.
I keep getting the following error: “Failed to create vault. Unable to create directory, unknown reason”.

Editing a file in an existing vault on my SD-card (copy-pasted the vault directory) gives me the FILE_NOTCREATED error.

I’m not an insider, so still on 1.0.3

Same here. Galaxy S9+. All permissions granted, sub folder used, …

what’s your Obsidian version? This should be fixed at least for some people in 1.0.4

My Samsung S8 is currently running:

  • Android 9
  • Kernel 4.4.111
  • Obsidian 1.0.4

And still, I cannot create a new vault or open an existing one on external storage.

Hi even after the update 1.0.4, I am still unable to set a folder in my external storage (USB). I have a screenshot of the error message it presents. My phone is a Samsung A21s running Android 11.


On my Android tablet I’ve been having the exact opposite problem:

SD card: no problems
Local Drive: NO opening or creating of vaults with error messages

A long time ago - before Obsidian - I, due to lack of space, changed my default download location from LOCAL drive to SD card.

So just a moment ago I switched back and made my Local Drive the “default
download” location again.

After a reboot Obsidian worked just fine on my Local Drive as well as still on my SD card.

I’ve switched back to my SD card being the “default download location” and Obsidian is still fine with both locations :slight_smile:


So if you are having a problem with Obsidian and the SD card on your Android phone, I would try the following:

Open Chrome browser | 3 dot Hamburger menu top right | Settings | below Advanced | Downloads | click on Download location | click on SD Card


After a reboot hopefully Obsidian will now work on your SD Card & still work on your Local drive.

Then later you can revert your “Download location” to your Local drive & Obsidian still should work on your SD Card.


I only had Obsidian on the Local drive on my Android phone - so when I popped in a USB stick earlier, Obsidian immediately asked for access permission for the SD card on my USB stick and thus both locations worked fine.

I can create a vault in my sd card, but I’m still unable to open my vault in my USB. I tried changing the download location and restarting my phone like you said, but it still didn’t work :’(((

1 Like