All Markdown Files Corrupted

Steps to reproduce

I really do not know what caused it; I am very confused

Actual result

At random, nearly all my files in my Obsidian vault became oddly corrupted and unreadable. This is a HUGE problem. Granted I should have been backing up my work and i hadn’t yet. Regardless, I lost about a months worth of Notes, and cannot currently trust Obsidian to not randomly F up and corrupt the files. I have pictures of what I’m going on about below.

Environment

I am using Obsidian v0.11.13
My vault is located in a separate partition and I use Obsidian in Windows 10 and in Linux, Debian based, specifically Parrot OS

I think my problem may be similar to this:

Although my corrupted files look a bit different.
My


Additional information

Here are some screenshots:

Did you use the new obsidian temporary feature in the core plugins?

I don’t think obsidian did this. This doesn’t look like random junk or zeros but the output of some other process or a filesystem brain fart.

  • Where are these files stored exactly?
  • what kind of partition?
  • How do you exactly access these notes?
  • Which third party plugins do you have installed?

Obsidian has a built-in file recovery, settings->file recovery. See if you can use that to recover some of your notes.

If you find reproducible steps. Please, let us know.

1 Like

From the output visible in the second screenshot, my guess is that you have some sort of graphing/diagramming/annotations plugin that’s malfunctioning. As others have said, knowing what plugins you’re using might help track down the source of the issue.

1 Like

That looks a lot like some kind of PDF file contents in your file.

I understand your frustration with the situation. It’s just as frustrating for us to see users lose their work, especially when we have no idea how to help.

Generally, I consider the chance that Obsidian causing this kind of corruption to be very rare. Our deployment pipeline goes through thousands of insider testers before reaching public builds (which you are using right now), used by some 50k+ active users (stats from GitHub downloads). If this was an issue with Obsidian itself, it would be seen much earlier and we would have gotten many bug reports about it.

The most likely cause for corruption usually comes from a few things specific to your setup:

  • Community plugins you may have installed
  • Other apps running on your device which also has access to your vault folder, especially synchronization apps
  • Possible filesystem issues, such as using a networked drive, or a USB drive that you disconnect abruptly.

If you’ve recently modified those files (within 7 days), you may be able to recover them from the File Recovery core plugin by going into Settings. Given the dates on your file name I’d say you probably didn’t.

The next best thing is probably to attempt to recover the file from a disk recovery software. The success chance isn’t great, but it might be worth a try. On Windows you can use the free tool called Recuva.

I use Obsidian in Windows 10 and in Linux

How are you synchronizing your files between the two? Most sync providers have some kind of version history tool you can use to recover previous versions of files - may be worth looking into that too.

4 Likes

It is an ext4 partition – this is just a partition of the same physical drive on which i have installed Linux and Windows so I can dual boot, but have my files separate so that they can be accessed by both OS’s. The vault itself is only 2 sub-folders deep in the filesystem.

I use obsidian in linux and windows at random.

Community Plugins Installed:

  • Advanced Tables
  • Better Word Count
  • Sliding Panes
  • Templater
  • Dataview
  • Reading Time

I tried using the file recovery core plugin, but it only worked for a handful of the notes.


Someone below mentioned it looks like the files are being mixed up with PDF contents. That is entirely possible. I have several PDF files and that I had linked. Also, at one point I tried to save an Excel file to see if it could be referenced. That didn’t work obviously – but I have no idea if it was the cause of any of the file corruption. I deleted those files from the vault. And even after that, several more of my files became corrupted at random. I was using Obsidian in windows, so I am thinking this is an issue relegated to windows and abruptly putting the PC to sleep without closing the program maybe.

At other times, I realized I have also had these Community Plugins installed:

  • Day Planner
  • Outliner
  • Paste URL into Selection

I liked to experiment with them all to see how they work.

General Info

I certainly understand that and think you are probably right. I really love Obsidian and the work that you guys do! I want to keep using it, but I want to figure out what cause all my data loss – and next time, I will certainly be backing up content.

I did try using a disk recovery software, it didn’t really work.


Regarding your bullet points

  1. this is most likely the source of the issue. I mentioned those in a reply above.
  2. I have no other apps accessing the vault folder
  3. The disconnecting abruptly could be caused by Linux. The partition is not permanently mounted, so I have to mount it every time I boot into Linux. So If I close Linux after using Obsidian and then boot into Windows (without closing Obsidian), perhaps that is part of the issue?
  • but it seems that the issue is occurring in Windows.

As a side note, just days before all the file corruption happened, I started using LaTex Mathjax in Obsidian for a project I was working on (Thankfully I didn’t loose that work). But just to list all things that changed before the files got corrupted, that is one of them.

How can you use ext4 on windows?

Backup your vault somewhere. I prefer you use Insync in Linux.
If you are in windows, use the Overdrive Client.

1 Like

So sorry, it is actually an exFAT partition.

I’m curious about that too. If you are sharing an ext4 partition with Linux and Windows, are you using some 3rd party driver or WSL2 to read that partition from windows? I would
suspect something getting corrupted from this setup or improperly unmounting before suspecting Obsidian or even community plugins.

1 Like

It is actually an exFAT partition, my bad. I am not sure if your answer still applies. I am curious about the mounting of the partition though, because it mounts and un-mounts in linux. You might be able to tell I am not incredibly technically adebt, just enough so to get myself in trouble, so I appreciate the help guys!

1 Like

hello, tell me what plugins do you use for this?

Hello arturradukevic453,

I do not use any plugins that do graphing or diagramming or annotations. It’s just not part of my workflow. I was just making a guess about where this person’s problem might have originated.

Feel free to explore whatever Community Plugins are available within obsidian, since I know there are some that exist for these purposes. However, I am not familiar with any of them.