Zoom does not work with all keyboard layouts

Steps to reproduce

Move the focus to one of the sidebars. type ctrl-minus. Text will get smaller. type ctrl-plus. Text fails to get taller.

Expected result

Text size should increase with ctrl-plus (or ctrl and turning the scroll wheel on the mouse)

Actual result

Increasing the size of the font does not work. Decreasing works.


  • Operating system: Linux Ubuntu 20.04.3 LTS
  • Obsidian version: v0.12.19

Additional information

The problem occurs only with my native keyboard layout (Swiss German). Changing the layout to US will fix the problem.
The zoom does not only affect text in the sidebars but also a picture in an iframe in the body of a note.

Edit: The problem is not the zoom function. Rather, Obsidian does not interpret keyboard layouts correctly. Using Setting/Hotkeys you can easily see that.

Should I retract this bug report and submit a new one for the handling of the keyboard layouts?

ctrl+ ctrl- and the scrollwheel operate two different kind of zoom.

1 Like

There’s a workaround. It appears that Obsidian accepts for all(?) keyboard layouts the same key for the Plus sign, i.e. the key two places to the right of the zero. On the Swiss keyboard, it is denoted as a ^.

Hi there,

I work on a MAcbook Pro 2021 with QWERTZ Layout for German Language.
I can zoom in using “command -” but nothing was happening when I pressed “command +”. So I played around a little bit and the working combination for zooming in is “command 0” so Command plus number zero.

I was looking to change it under hotkeys, but didn’t find it there. That would be nice to have.