Zettelkasten Prefixer - bug with date setting

Good morning!

After getting used to Obsidian, I also started using some plugins, amongst them the Zettelkasten Plugin.

I did opt to change the format though, setting it to YYYYMMDD - I’m fine with having date as a UID, no more detail needed in the name.

Then I started using everything and was astonished. Every time I clicked on the new Zettelkasten note, the date was wrong. Off by a few days, every time. Year and month were ok, but it did set the day to 26 on the 21st. I checked my system settings and checked for time and date settings in Obsidian, just to make sure it didn’t get false data. Couldn’t solve it.

Now, by chance, I just made two or three new notes and found out what happened: The prefixer does not actually set the date, but year, month and then a number, increasing by one for each new note. So the first note hat “27”, the next one “28” and so on - the “DD” part of the prefixer, well, it isn’t prefixed :wink:

I think you are confusing what the Zettelkasten prefix is (a unique ID).

If you create more than one note per day, add hours or even minutes too.

true, I might not be using it right - I would still respectfully consider it a bug, if a prefix is allowed but not correctly filled according to the settings.

Or better said, it shouldn’t allow any setting that modifies the “DD” part of the ID incorrectly. Perhaps the prefix should just be a fixed setting? In any case, thanks for clearing it up. I’ll try the full prefix and see if the “day” part is filled correctly.

This is not a bug. It’s indented behaviour. If we detect a collision in the ID, we increment the date by one unit until there is no collision anymore.

The problem is that you are not ZK ID as a Unique Identifier but just as a prefix. My adivise is to use YYYYMMDDHH and then delete the hours if you don’t want it.

Thank you for clearing that up, makes sense

1 Like