Workaround for making [[Wikilinks]]-syntax compatible with Ulysses

The writing experience in Obsidian keeps getting better, but I really like writing in Ulysses: it’s beautiful, syncs fast between iPad and Mac, has great grammar and spelling support, enables merging/splitting notes, offers great export options, and it can be set to work with an external folder of Markdown files, such as an Obsidian vault. Unfortunately, it doesn’t play well with [[Wikilinks]]-syntax. One day, I hope that Ulysses will modify its quirky Markdown syntax to accommodate it, but for now, if you type [[ in Ulysses, you get a URL link that starts with [. I noticed, however, that if I open an .md file that already has [[]]-syntax, it is rendered as \[\[backlink]] in Ulysses. And so I tried reversing it, and sure enough! If you use the back-slashes when writing in Ulysses (in the external folder used as an Obsidian vault) and then open the .md file in Obsidian, it appears as a normal [[Wikilinks]] – without the backslashes.

So my workaround is to set Keyboard Maestro to convert the typed string [[ to \[\[%|%]] (but only in Ulysses). This also positions the cursor between the wiki-brackets. Of course, there’s no autocompletion in Ulysses, but for text entry, this seems to work well. (This will also work with a snippet utility like TextExpander, but the advantage of Keyboard Maestro is that you can limit it to firing in Ulysses with the same keystrokes used in Obsidian.)

While I was at it, I made a KM macro that takes selected text and converts it into a Wiki-style link.

The two screenshots show the settings.

This is somewhat related to this discussion: https://forum.obsidian.md/t/support-real-markdown-links-between-notes.

6 Likes

Hi @AutonomyGaps: really nice workaround! I also work with both Ulysses and Obsidian. My problem is: when I create a footnote in Obsidian it does not show properly in Ulysses (it remains in the text). Have you encountered/solved the same problem?

Works fine for me, actually. The footnote shows up differently in Edit mode, but if you switch to preview mode in Ulysses, the footnote is properly positioned at the bottom of the page.

@AutonomyGaps , thanks! I noticed also that if I open the file with Ulysses from the folder instead of launching it within Obsidian, notes are properly formatted. :slight_smile:

Hi! @AutonomyGaps I still can’t make it work for some reasons… I tried switching in preview but the footnotes is still not a footnote… it appears something like ^/[text of the note] in the line…
Could you tell me what you do exactly? Thanks so much for your help!

Here’s what I do. I hope this helps! I create a new note in Obsidian:

Footnote about how wonderful Obsidian is,[^1] and here's a longer one.[^bignote].

[^1]: meaningful!
[^bignote]: I could go on and on, but I probably shouldn't. Ulysses is also cool.

==================

Then I open the same sheet in the corresponding “Extrernal folder” in Ulysses. It looks like it doesn’t work:

=================
But if you Preview it in HTML (or Word or PDF), you can see that it’s there:

Hi @AutonomyGaps and thanks so much! Unfortunately it does not work with me:

  1. In Obsidian I create the note ^[text] (I have to put the carrot sign outside of the square brackets otherwise it does not recognise it).
  2. Then I open the file from the external folder but then the footnote is not rendered, even in preview…
    I am quite baffled. Again, thanks so much, and Happy Easter!

I think that this is your problem:

^[text] (I have to put the carrot sign outside of the square brackets otherwise it does not recognise it).

The ^ has to be INSIDE the brackets. This is explained the Help vault, under “Format your notes#Footnotes”.

Hi there, and thanks again for taking the time to respond. I might be really dumb though… I tried putting the carat outside the brackets, and all I get is: 1. Smaller text in edit mode; 2. no footnote in the preview mode; 3. Same result in Ulysses.
I found a workaround, which is using an app called “text” which recognises the footnote (made in my original, faulty way). Then I can also open the file with Ulysses and everything works. This is a step too many, but I cannot figure out what I’m doing wrong now.
I tried: [^1]:text and it does not work. I tried [^ text]: and it does not work either… Maybe what I’m really not understanding is the meaning of indenting the text of the footnote (as it is said in the Help folder).

An update: it works with I.A. writer as well with both syntaxes (^[text] and [^text]: so I might just switch to IA writer… I prefer Ulysses, but IA writer just works and the conversion to doc is as good as Ulysses’s. Also, they both work with bookends…