Word count and backlinks panel in bottom right is always obscuring text

Steps to reproduce

In any text note, the text that i’m typing eventually gets to bottom line. From there, the window is scrolling with each new line, but the focus generally stays with the bottom line of Obsidian window.
The problem is that bottom line has a counter panel (Backlinks, Words, Characters) that occupies a part of the line. For split-screen scenarios (having a video call + using Obsidian for notes) it occupies almost entire line.
This panel obscures text and it’s not visible what I’m typing.
I’m used now to press Enter like 10 times to create space and get away from the bottom panel with Backlinks count. Still, before I know it, I land at the last line again.

Expected result

The panel with Backliks, Words, Characters disappears if there is active text being typed in that line. Or any other outcome that does not hide actively typed text behind an overlay panel.

Actual result

I can’t see anything that I type in the last line. The text editor always lands me in the last line as I type more text. It makes Obsidian unusable.

Environment

  • Operating system: MacOS Monterey 12.6.2
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.1.9
    Installer version: v0.15.9
    Operating system: Darwin Kernel Version 21.6.0: Sun Nov 6 23:31:16 PST 2022; root:xnu-8020.240.14~1/RELEASE_X86_64 21.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on

RECOMMENDATIONS:
none


Additional information

1 Like

As a current workaround you could use this CSS Snippet:

	.workspace-split.mod-vertical.mod-root {
		padding-bottom: 28px;
	}

Another alternative is this one:

	.status-bar {
		opacity: 0;
	}
	.status-bar:hover {
		opacity: 1;
	}

The status-bar will only appear if you hover it.

1 Like