Stop status bar from hiding text while typing, or hide status bar to avoid the issue?

Things I have tried

I’ve searched the help page for “status” and read several possibly-related forum posts about the status bar, and haven’t found anyone talking about how the status bar can cover up text while typing, if you’re typing at the bottom of the page. I’ve looked through the settings and couldn’t find anything that lets me prevent the status bar from hiding text while typing, and I also couldn’t find any way to hide the status bar. I also tried to see if there was a way to make the status bar just take up the whole bottom of the note instead of the right corner (figuring if such a setting existed it would surely make it so typing didn’t get hidden), but couldn’t find any setting for that either.

I’m using the Default theme on macOS in Obsidian 1.0.0, by the way, if that matters.

What I’m trying to do

  • I would also assume that if I’m typing, the status bar wouldn’t cover up the words I’m currently typing if I’m typing near the status bar.
  • I would assume that I should be able to toggle or disable the status bar entirely, especially if there’s no way around the above issue. (And in macOS I would assume I could do that in the View menu.)

I’m not sure if this is only a problem since 1.0, but I never noticed it until now, so the timing seems possibly related?

Is there any way around this? So much of Obsidian is so wonderfully designed that this issue really surprised me, so I surely must be missing some way around this.

1 Like

Do you have any CSS snippets? Have you tested turning off community plugins to see if one is interfering? Do a quick test in the Sandbox help vault?

It shouldn’t be covering the text. Sounds like a glitch you’ll be able to solve somehow.

It might help to show your “Show Debug Info” results, or share a screenshot of your app, so we can try to spot potential glitches or sources of potential problems.

1 Like

Thanks for the suggestions. I just tried turning off my two (very minor) CSS snippets and my two community plugins (dataview, text format), and the same behavior happened. I also tried the sandbox help vault and the same behavior happened. Here’s a screenshot:

You can see what I’m talking about down at the bottom-right. The cursor and nearby text in that screenshot is hidden by the status bar. I did this by creating a new note in the sandbox, then typing ‘line’ on every line until I was at the bottom and then typing random keys because i couldn’t think of a good test sentence. Does it behave this way for anyone else, or is it just me?

Below, I’ve scrolled down a little with my mouse to show you what was hidden and where the cursor is (it’s at the end of that line):

I hope this clarifies what’s happening. I’d really love for the status bar to be the full width of the note and the text not get blocked by it, or I’d really love the ability to simply turn the status bar off (a lesser fix, IMO, but acceptable for me at least since I don’t really care about the status line). Or maybe keep the status bar as it is, in the corner, and if the cursor is going to get obscured by it, scroll the screen automatically? (Though that sounds like a more complicated fix, and I don’t think it would be all that elegant to use like that.)

1 Like

Yeah you have some kind of a glitch. The status bar for me, is the full width of the app, even below all the side panes.

Please, if you will, share your “Show debug info” results. Cmd-P for the command palette, and type “Show debug info”. Paste the results here.

Although the fact that it also happens in the Sandbox is weird. Did you update to the latest installer? If not, try that first. Download the latest version and reinstall.

Here’s the debug info:

SYSTEM INFO:
Obsidian version: v1.0.0
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:20:05 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T8101 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

I’ve got installer 0.15.9, but I’m not sure if that’s the most recent, so I’ll do as you suggested and download and reinstall.

1 Like

Well, after downloading and reinstalling, I get the exact same behavior. Here’s the new debug info:

SYSTEM INFO:
Obsidian version: v1.0.0
Installer version: v1.0.0
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:20:05 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T8101 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

It is indeed a newer installer than I had, but that didn’t change this issue. Any ideas? Or should I file a bug report?

1 Like

Ah, it’s a known issue. That’s all I know for now.

1 Like

As long as it’s known, that’s good. Thanks. I’m not as good at searching through issues/bugs on discourse as I am on github, I guess!

I’m glad to see it’s a known issue. I use Obsidian Git which usually displays its latest status on the status bar. Right now I have no way of knowing the current backup status of my vault.

I’m having the same issue and I don’t have any community plugins installed.

1 Like

I added the following css snippet:

.app-container .status-bar { position: unset; } 

and it docks the status bar at the bottom of the obsidian window!

2 Likes

Nice, that seems to do the trick for me! I tried playing with CSS myself but whatever I tried didn’t help. Thanks!

(I’m marking that as a solution. If that’s not what I should be doing, since this seems to be an actual bug, let me know.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.