[Windows 10] Cannot open the Documents folder or user profile folder as a vault

Steps to reproduce

  1. Click on “Open another vault,” then click on “Open” next to “Open folder as vault.”
  2. Choose either the Documents folder or your user profile folder (the one that contains the Desktop, Documents, Downloads, Music, Pictures, etc. folders) as the folder to be opened as a vault. Usually the folder structure will be this:

         - C:\Users\[my profile name]
         - C:\Users\[my profile name]\Documents

Expected result

A new vault in one of these specified folders will be created.

Actual result

A new Obsidian window opens with an error message in the middle of it. Obsidian must then be closed in order to get back to a functioning vault. If I later attempt to open the new vault from a functioning Obsidian vault, the same result occurs again in a new window again.

The error message begins: “Error: EPERM: operation not permitted” and then lists a particular hidden or system subfolder as the issue (the folder varies depending on which location I’m trying to add the vault at).

For the user profile folder, the error begins: “Error: EPERM: operation not permitted, scandir 'C:\Users\[…]\AppData[…]”

For the Documents folder, the error begins: “Error: EPERM: operation not permitted, watch 'C:\Users\[User name]\Documents\My Music”

Screenshot:

Environment

  • Operating system: Windows 10
  • Obsidian version: 0.12.12

Additional information

Things I have tried

  • opening affected folders in an elevated instance of Obsidian e.g. Open as Administrator (doesn’t make a difference)
  • after the vault was created (but couldn’t be opened), I tried manually editing the app.json and core-plugins.json files using a functioning vault’s files as examples. The app.json file was blank except for “{}” if I remember correctly. I pasted text from the functioning vault’s files, and I turned off some of the plugins in both json files. This didn’t help, and the core-plugins.json file gets overwritten each time I try to open the vault.

Hello, I am sorry but we won’t fix this. We won’t attempt to handle or circumvent hidden system folder/symlinks.