EPERM error in certain folders when trying to use a folder to create a vault


(On Windows 10) Can’t create vaults in Documents folder or my user profile folder (the folder that contains Documents, Desktop, etc.). When I try to do so, I get an error that begins: “Error: EPERM: operation not permitted” and then lists a particular subfolder as the issue (some hidden folder, depending on where I’m trying to add the vault).

Things I have tried

  • opening vaults in unaffected folders (has the expected result; unaffected folders can be opened)
  • opening affected folders in an elevated instance of Obsidian e.g. Open as Administrator (doesn’t make a difference)

What I’m trying to do

(In Windows 10)

Create a vault using the following existing user folders:

  • C:\Users\[my profile name]
  • C:\Users\[my profile name]\Documents

What happens

When I try to create a vault using the aforementioned existing folders, I get errors such as “Error: EPERM: operation not permitted, scandir 'C:\Users\[…]\AppData[…]” and “Error: EPERM: operation not permitted, watch 'C:\Users\[User name]\Documents\My Music”…

Edit: I noticed that “Documents\My Music” is a weird path. I turned on the option to view hidden files and folders in Explorer and didn’t see any such path. I tried to write the path to navigate to it and got an Access Denied error. I found the Explorer setting to “Hide protected operating system files” and turned that off, and found some kind of link (like a symlink or something like that) to My Music in the Documents folder. I looked at the properties for that folder and basically all permissions for that link are nonexistent–as I’m sure is intended.

So I think my questions is, how can I get Obsidian to work in this very commonly used folder (Documents), when Obsidian throws an error because there are subfolders in this folder that Windows does not want a user to access?

How to See Hidden System Files in Windows 10 (techbout.com)

Edit #2: Reported a bug here: [Windows 10] Cannot open the Documents folder or user profile folder as a vault - Bug reports - Obsidian Forum

I’m going to reply to myself for other people with the same issue. Though I don’t have a solution yet (haven’t had time to try), I think the problem/solution might be with the Sync plugin, which I’m using. In the Sync plugin options, there is an option to exclude certain folders from Sync. I’m hoping that this is where the solution lies.

The vault creation process never gets to the point where Sync options can be edited, so if the issue is with the Sync plugin, I don’t know how to resolve it. But I think the Sync plugin is turned off by default when creating a new vault.

Going to repost this in the Bug reports forum.

Edit: Reported here: [Windows 10] Cannot open the Documents folder or user profile folder as a vault - Bug reports - Obsidian Forum

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.