When a large folder present, renaming files/folders doesn't work

Steps to reproduce

  1. Copy a large folder to the vault (I tested with 2,476 files in 256 folders totaling at 95GB)
  2. Try to rename existing files/folders or create a new file/folder and name it.

Expected result

Folder/file should rename to what I typed.

Actual result

It looks like it’s renamed in Obsidian but if you go to the folder it is not and when you restart Obsidian the changes will not be saved.

For example if you create a new folder it will remain “Untitled” in the system even if you rename it in Obsidian and it seems like it has worked.

When restarted, Obsidian will re-read the real names.

Strangely though, if you rename a file/folder directly in Windows explorer it will be correctly reflected in Obsidian.


  • Operating system: Windows 10
  • Obsidian version: v0.11.5

Additional information

where is this folder stored exactly?
what happens if you wait?

do you get errors in console ctrl-shift-i?

The folder is in a local hard drive.

I left it for around 30-40 minutes and it worked :thinking:

No errors in the console.

we’ll look into it.

This is caused by the cache trying to understand your vault structure and the rename waiting on that process before it can safely do so with/without updating links to it.

If you wait a bit until Obsidian goes idle, it should work again.

In theory, the cache probably shouldn’t read large media files anyway. I will address this which will speed up the process for the next release.

1 Like

fixed in 0.11.8