When a large folder present, renaming files/folders doesn’t work <respawn>

This bug:
unfortunately seems to have reemerged in 0.11.13

Steps to reproduce

  1. copy large folder to vault (the size isn’t as important as the amount of files/folders >2000 seems to be to much)
  2. Try to rename existing files/folders or create a new file/folder and name it.

Expected result

normal re-naming

Actual result

untitled (.md) with no renaming


  • Operating system: Ubuntu 20.04 KDE (same in Gnome)
  • Obsidian version: 0.11.13

Additional information

Interestingly neither Graph view nor editing content inside a file is slowed down. Obsidian handles more than 2000 files perfectly except that new files have to be renamed in the file browser or terminal… (which is slightly unpleasant)


  • What’s the size in MB of your vault?
  • How many files do you have?
  • How many non-md files do you have?
  • What happens if you wait?
  • Where and how are these files store exactly?
  • the size of the vault is around 200 MB
    ( I tried with a dictionary in 3 3GB junks and nothing happened, but with 26Mb in 3000 files it was reproducible)

  • ~2300 files

  • ~2000 md

  • ~300 non md (csv, jpg, pdf)

  • waiting doesn’t help it stays untitled

  • SSD local (backup to cloud, but that shouldn’t make a difference?)

I found a work around that is ok for me: it does not happen in smaller subfolders, i.e.

Vault root (here it happens)
— big folder A (here too)
— small folder B (here it doesn’t)

It’s strange and I’m confused about this behavior, but I can live with setting new file creation to a subfolder, you should probably still keep this on your radar imho …

Does this happen if you keep the same vault in a regular directory not handled by backup/sync service?

Ok it’s getting stranger. I just copied the folder and tried it directly in my home directory and here it works. It seems somehow that the drive backup is interfering, but this is the first time this happened to me… other programs are able to rename files in large folders and obsidian is able to create untitled 1, 2,3… immediately and also to write into those files… Probably a rare occurrence… Still strange, isn’t it?! Anyway, probably not the most urgent bug (if it’s your bug at all)

PS: I just realized something that might be of interest: there is a short delay in the home folder too but less then a second

I don’t know what your backup solution is, but I would venture guess that the files aren’t really there, or there is some form of filesystem in userland to fake regular directory.

What do you use exactly?

I use Google Drive and insync…
The files appear edited and exactly the same (name and content) on my laptop…
My uneducated guess is that obsidian is a bit slow with many files and that combined with some kind of lock when updating to the cloud results in this happening.
I have to say this analysis is close to technoshamanism :wink: I have no clue…

Can you turn it off, use the directory, and then turn it on? Or does the directory disappears if insync is not active?

You are right it is somehow connected:

  1. turn off insync
  2. new note
  3. re-name
  4. barely noticeable delay and there is the new name
  5. edit …
  6. turn on insync
  7. voilà everything is synced

I’m still not sure how it happens, but anyway.
Thanks a lot for your help!