Was the Issue with Wrong Creation Dates Ever Resolved?

I am running Obsidian (no Sync) on a MacBook Air (M2, Ventura 13.4.1 (22F82)).

What I’m trying to do

I have a template for the header of my notes that includes {{date}}{{time}} to capture the date and time the file was created.

Things I have tried

I have been using Obsidian for over a year now, but I just noticed that these creation datetimes have been rewritten somehow by Obsidian’s internal processes.

I found this closed topic and this feature request. Neither offers a solution or seems to get any traction.

Do you have any recommended actions to: a) restore my original creation dates, and b) prevent this from happening going forward?


Are you using another sync/cloud tool?

Typically this happens when doing cross-platform or cross-filesystem file transfers. It’s not unique to Obsidian.

To answer your question, no it is still an open feature request. Hopefully something can be solved for Obsidian Sync. But if an external tool is changing the metadata, there is nothing really that Obsidian can do about that.

There are ideas in other threads, for writing a script to modify the metadata based on stored YAML or your {{date}}{{time}} info.

I’m not aware of a way that local Obsidian would be changing those dates. I suspect you are using a sync/cloud tool, or some plugin that might be causing it. Or if you’ve ever moved the files by copy/paste or similar (sometimes, but that is usually more when copying to other filesystems).

I remember having this issue in the sandbox vault without using any sync here: Wrong Date Created Property - #4 by I-d-as

You were part of that discussion, and very helpful, but I figured I might as well link it. Thanks.

1 Like

Oh right, thanks for reminding me that you had tested that!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.