Wacom input problem in canvas on mac

Steps to reproduce

Using a Wacom tablet to click and drag an element on the canvas.

Expected result

Being able to move the element.

Actual result

Nothing happens. I’m unable to click and drag after the new update. It worked before.

When hovering a card I get the drag cursor, but it’s not moving when I click and drag. However, if I use my trackpad and click on the canvas background it seems like it’s “resetting” the bug and I can use my tablet pen to click and drag again. But if I add a new card the bug is back! Quite annoying.


  • Operating system: macOS Monterey 12.1
  • Debug info:
    Obsidian version: v1.1.16
    Installer version: v1.0.3
    Operating system: Darwin Kernel Version 21.2.0: Sun Nov 28 20:29:10 PST 2021; root:xnu-8019.61.5~1/RELEASE_ARM64_T8101 21.2.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 11
    Plugins enabled: 9
    1: Sort & Permute lines v0.6.1
    2: Editing Toolbar v2.2.3
    3: Obsidian42 - BRAT v0.6.36
    4: TickTick v0.3.0
    5: File path to URI v1.4.1
    6: Translate v1.4.4
    7: Natural Language Dates v0.6.1
    8: Imgur Plugin v2.2.1
    9: Khoj v0.3.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Test the canvas with a Wacom tablet and see for yourself if you can replicate the bug. The fact that it worked before and is not working now means something happened with the update. Many user use tablets, especially in design, media and so on.
I tested the Sandbox Vault and the bug is there too.


I’m not sure anyone on the team has a wacom tablet to test and repro this, so it’d be helpful if other users could sound in too!

@pookeyblow downlead and reinstall Obsidian. Try in the sandbox vault.

@rigmarole I don’t recall in you have a wacom tablet or not.

Yep, I do have a Wacom. I can reproduce this in the Sandbox.

Dragging and resizing seems broken. It is broken for me in Obsidian 1.1.16 (installer 1.1.9) MacOS Monterey 12.6.3

Updated to 1.1.16 installer. Same issue.

The drag event just doesn’t seem to happen. If I drag, but finish the drag on top of the card, it registers as a straight click, and selects (or activates-edit) the card.

Dragging/making connection lines still works.

Drag-selecting text inside a card still works.

Clicking (selecting, following links, activating edit) still works. Except you can’t deselect cards by clicking in a blank space in the canvas.

And like pookeyblow, I can temporarily “fix” the bug by clicking with the trackpad. A new card, or deselecting all turns the bug back on.

Trackpad is fine.

Wacom still works fine in Windows 10.


has this ever worked on mac?

Yes, it always worked on Mac. I haven’t been using Canvas for a couple weeks though.

It never worked well for me, and I’m on a Mac. It’s basically dragging, changing the size of the elements, and deselecting them. Since I have a Wacom Intuos which basically works like a trackpad, some features work, but it’s totally annoying working with it.

It would be great if this bug would be fixed, because I’ve been using a Wacom for all my career, and I’ll never use a mouse. Currently it’s very irritating and I don’t use the Canvas. I’d love to though, because it’s great!

Hi, Just weighing in with a few things. I have a mobile studio pro and I have the following issues in Canvas Mode.

My pen click (using the button that normally acts as a left mouse click) seems to only allow me to click on to edit something, not move any move resize or connections. Same for tapping with the pen nib.
With pen, I can click between two pages, but I can’t click the background to deselect.
With my finger I can often move a note, but never resize. I can deselect though.

I also use a Samsung fold and with the pen on that I can move and resize with my finger, but only resize with pen.

Canvas is my biggest focus for using obsidian because its what is missing in notion imo, and I love using pens. Let me know if there is any thing I can do to help test and figure out these bugs.


I have the same problems with my Wacom Intuous as described in the OP. It is not usable.

Hi friends. I have same problem with mac OS Ventura 13.5.2 and Wacom Intuos Pro. I can´t drag elements in Obsidian´s Canvas with my pencil…

1 Like

Same issue

1 Like

Have tried this and found the same issue in the Sandbox.

Steps to reproduce

I open a canvas. I can add notes, and drag them around the canvas.
I write in one note.
(Specifically, I write some random letters, press return, then write some random letters)
Then, while the purple outline is still active and the cursor flashing, I use the cursor to click outside of the note with the idea of exiting it.
However, the purple outline remains as does the editing bar above the note.
I then need to press escape to exit the note/remove the purple outline.
From this point on, I can no longer drag notes around the canvas until I close and reopen the vault. It is frozen. But, I can still edit notes

If I write one line of text and don’t press return before clicking outside the note, this doesn’t happen. The purple outline does go away and in these cases, I can continue to drag notes around the canvas.

Did you follow the troubleshooting guide? [Y/N]

Yes. And I used the sandbox.

Expected result

I expect to be able to drag notes around the canvas.

Actual result

Notes are frozen.


Obsidian version: v1.4.5
Installer version: v1.4.5
Operating system: Darwin Kernel Version 22.3.0: Thu Jan 5 20:53:49 PST 2023; root:xnu-8792.81.2~2/RELEASE_X86_64 22.3.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

I am using a Wacom pen input - Could this possibly be giving unusual click input?


I’ve found this also happens if I press ESC to exit the note.
That is, I open the canvas
I add a note
I type in the note, return, type
Then I press ESC to exit the note
But the purple outline does not go away
And from that point on I cannot drag notes around the canvas

Try with a mouse

Using a mouse seems to work.

It’s strange the Wacom pen and tablet I use cause the same hand cursor to appear over the note. When I click, they both show the hand symbol ‘grabbing’ the note. But, the note is only moveable if when using the mouse.

Is a fix for this likely to appear?