Virtualized OS/Virtual Machine: Can't click on table calls to edit them

Steps to reproduce

  • open help vault
  • on the “Start Here” note, go into source mode
  • right-click and add a table
  • switch to LP
  • try to click on one of the table cells to edit it or try to move columns
  • does not work

Did you follow the troubleshooting guide?


Expected result

I can click on every cell and edit it.

Actual result

I can only sometimes click on some cells, but most of the time I can’t click on any cells.


    Obsidian version: v1.5.3
    Installer version: v1.4.16
    Operating system: #1 SMP Thu Oct 5 21:02:42 UTC 2023
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 8
    Plugins enabled: 0


Additional information

I can still navigate into the table cells with the arrow keys.

I have a screen recording of the bug, but I can’t upload that here.


I’ve been dealing with the exact same issue since the new table core plugin rolled out. It’s very frustrating to have to change to source view to edit tables or use the arrow and tab keys to navigate cells in the editor. I only have this issue on Obsidian packages for Linux though. Other OSs like macOS work as intended in this regard.

1 Like

Same issue here. I’m only facing this on a Debian distro – no issues in Windows or on my Fedora machine. I currently have to switch to the source mode to do anything, and word wrap doesn’t seem to work in that mode so it makes it pretty difficult to use.

I have the same issue. I tried the following steps to get rid of the problem, all with the same outcome:

  • Disable Advanced Tables community plug-in + restart Obidian
  • uninstall Advanced Tables community plug-in + restart Obsidian
  • disable all community plug-ins (Restricted Mode=ON) + restart Obsidian
  • uninstall debian package (with -purge option) + restart linux
  • Run 1.5.3 from AppImage - issue present
  • Run 1.4.16 from AppImage - issue absent
  • reinstalled .deb package - issue present

Tested all this with Sandbox vault as well, same results

I do not have any custom themes

Same as OP, my only option is editing in source mode = pita.

I have bound a hotkey for switching, but still :nauseated_face:

Debug info :

	Obsidian version: v1.5.3
	Installer version: v1.5.3
	Operating system: #1 SMP PREEMPT_DYNAMIC Fri Jan 12 18:20:08 PST 2024 6.1.60-08594-g03a802b9a072
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 6
	Plugins enabled: 5
		1: Omnisearch v1.21.1
		2: Tasks v6.0.0
		3: Editing Toolbar v2.4.0
		4: Shell commands v0.21.0
		5: Mind Map v1.1.0

	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.
xxxxxx@penguin:~/downloads/obsidian$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye

Same issue, here.

yep, thank you for that. I found some other thread with this topic. Looks like a systemic issue, huh… at least it should be reproduceable with ease :crossed_fingers:

We don’t support WSL.

On linux, is obsidian running in X11, XWayland or Wayland?

WSL 2 supports both X11 and Wayland. How do I determine with one of those obsidian is using?
(I am using the official appimage of obsidian)

I’m having issues in Debian via X11, but it works fine on my Fedora/Wayland machine.

Post a screen recording of it happening in the sandbox vault.

What is your mouse? shows a quick set of examples. Note that when I change to live preview I’m clicking each time the mouse pauses. When I click below the table the cursor starts there but text gets appended to the end of the table. When I add a new row, I can’t edit text except for in the final column (apparently). Let me know if you want to see me try anything else.

What is your mouse/pointing device?
Are you running the latest appimage from our website?

I’m using a Logitech MX Master 3S. Also, just realized I didn’t mention this earlier, but this is a VM (VMWare Workstation Pro). Obsidian works just fine on the host (Windows 11) but not in any Debian-based X11 VM it appears. I don’t have non-deb VMs to compare against, however. I’m willing to install one if you think it will help.

And yes, just downloaded latest AppImage to make sure the bug replicates, and it’s still there. Slightly different behavior at times, where I can click in the first column on one table but I couldn’t on another one, but overall most of the cells are not editable in the Live Preview.

You should try Debian native. It possible that’s the Virtual Machine Software who is not passing the mouse events properly.

I don’t have an extra machine to natively install Debian to test with. Also, even if I did, my use case doesn’t change where I need to use this VM for my job, and due to security reasons I can’t just use the version on my host system. If it helps I’m happy to open a separate bug request or forum post if you feel this needs to be handled elsewhere.

My request was to figure out if this is a problem of VMware (they don’t emulate some mouse events well?!?). If that’s the case you should file a bug report to them.

I use obsidian on linux and tables work fine.

The same issue is happening for me on ChromeOS running in Crostini and obsidian_1.5.3_amd64.deb. This is on an HP Dragonfly Elite Chromebook.

Chrome version 122.0.6261.35 (Official Build) beta (64-bit) if that helps at all.

All these reports have in common the implicit or explicit use of a virtualization environment.
I again think that the virtualization layer is not passing all the mouse events from the host to the guest.

Then why is the obsidian app the only one where issues appear? I don’t have issues with any other apps, or other electron apps (e.g. discord) as well.