Vim mode 'o' in list always inserts spaces on newline instead of tabs

image

o when in a list inserts single spaces instead of expected behavior of either:

  • Tab whitespace inserted on newline corresponding to indent level
  • with or without a continuation of the list item (i.e. -, >, +), which would be behavior equivalent to Enter/ at the end of the line.
  • Or, empty new line.

Steps to reproduce

This is replicable in sandbox with vim mode enabled on v1.1.9. Default settings has Editor>Behavior>Indent using tabs on, but when using spaces, the indentation is expected behavior equivalent to the first case above, with the number of spaces corresponding to Tab Indent Size in Editor>Behavior:
image

Ideas

This is fixed in actual vim with commands like set listchars=tab, though this and none of the following seem to be valid commands with or without the Vimrc Support plugin.
(Or perhaps commands like set copyindent/autoindent/smartindent/expandtab which idk - may or may not overlap with Editor>Behavior>Smart indent lists)

1 Like

thanks