In vim mode "o" does not automatically create lists

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with community plugins and custom CSS disabled and see if it’s still reproducible. Alternatively, you can use the Sandbox vault (lower left corner ? → Open Sandbox vault).

If it’s an issue with third-party plugins or themes, try contacting the author for help.

Mobile-specific bug reports should be filed here:

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Starting from a new note, insert the followling:

1. My test list

Then with the cursor on that line, hit o to open a new line, you get:

1. My test list

Expected result

1. My test list

Actual result

1. My test list


  • Operating system: Linux
  • Debug info:
	Obsidian version: v1.1.9
	Installer version: v1.1.9
	Operating system: #63-Ubuntu SMP Thu Nov 24 13:43:17 UTC 2022 5.15.0-57-generic
	Login status: not logged in
	Insider build toggle: off
	Live preview: off
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 3
	Plugins enabled: 3
		1: Quick Latex for Obsidian v2.5.1
		2: Citations v0.4.5
		3: Remotely Save v0.3.25

	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I think this is pretty minor, because the bug is specifically related to o, and staying in insert mode then hitting <CR> behaves correctly.

I’m closing this one. Please see the links below.

Existing FR with some workarounds:

Existing FR:

Existing bug reports

1 Like