Vim is lagging when using jk

After the update to 1.0 my vim has a different behavior.

When I hold in “j” or “k” the cursor disappears and then reappears when I release the key. It reappears at the correct spot down or up the text. But because it disappears I don’t know for how long I should press the given key. For me it is now almost useless to hold the “j” og “k”, and I instead end up tapping several times to go down or up, line by line.

I don’t have this problem in VSCode or terminal. I have tried this in restricted mode, but with no success. I’m on macOS 10.15.7.

Do you know what the problem could be?

Thanks in advance.

moved to help for not following bug report template. I can’t reproduce this in the sandbox vault.

Try to post your “Show debug info” from Obsidian.

Might be related to this: Unusual lag since 1.0.0 on Windows (not Mac) - #17 by jazavchar

SYSTEM INFO:
Obsidian version: v1.0.3
Installer version: v0.15.8
Operating system: Darwin Kernel Version 19.6.0: Tue Jun 21 21:18:39 PDT 2022; root:xnu-6153.141.66~1/RELEASE_X86_64 19.6.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Blue Topaz
Snippets enabled: 1
Restricted mode: off
Plugins installed: 31
Plugins enabled: 18
1: Calendar v1.5.10
2: Dataview v0.5.47
3: Excalidraw v1.8.1
4: Vimrc Support v0.8.0
5: Advanced Tables v0.18.0
6: Periodic Notes v0.0.17
7: Natural Language Dates v0.6.1
8: Recent Files v1.3.5
9: Tracker v1.10.9
10: QuickAdd v0.7.0
11: Buttons v0.4.19
12: Templater v1.16.0
13: Style Settings v0.4.12
14: Tag Wrangler v0.5.5
15: Highlightr v1.2.2
16: Admonition v9.0.5
17: Readwise Official v2.0.1
18: Open vault in VSCode v1.2.1

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Thanks for the reference post.

When I turn on restricted mode the lag is still there. But if I create a new vault, then the lag disappears. So there have to be something problematic with exactly this vault.

Do you have any suggestions on how I could proceed to detect the issue?

Did you make sure to restart Obsidian after toggling any plugins, or turning on restricted mode? If not, then I don’t think you’ve ruled out a plugin yet.

I would also test (one at a time) disabling your custom snippet, and switching to the default theme.

It also couldn’t hurt to try downloading the latest Obsidian installer and reinstalling.

And make sure all themes and plugins are up to date, if you haven’t already.

Might be related to this issue? But that is not vim specific.