Vim: Input when it's not in insert mode with Korean

Things I have tried

If I turn off the legacy editor mode, it will be input even if it is not in insert mode when converted to Korean.

Can this be prevented?

What I’m trying to do

I want to prevent input when converted to Korean.

have you tried to turn on reading mode? It might be going into edit mode by default. you can change this in the preferences , editor.

Thank you for your kind reply.

It’s really hard to explain due to my poor english.

I’m using vim mode and there’s no problem when I turn on ‘Use legacy editor’ mode.

But when I turned off the legacy editor mode, problem happens.

In legacy editor mode, even if I converted to Korean, if I’m in command mode, nothing happens when I try to write something. So there’s no problem at all.

But when i turn off the legacy editor mode, if I converted to Korean, even if I’m in command mode, characters are substituted by korean charater that I stroke.

What I want is if I converted to Korean, nothing should happen in command mode.

This is my problem… );

thanks for the information. I suspect this is a bug when using Korean. The Legacy Editor is going to be discontinued soon,
so getting this fixed should be important to the developers.
I suggest submitting a bug report.

1 Like

Thank you for your suggestion.

I might try submitting a bug report!