Vim command line (":" in normal mode) is in black on black and overlaps Obsidian buttons

Steps to reproduce

  1. Set the iPhone in dark mode (Settings > Display & Brightness > Appearance).
  2. Use the latest (1.5.12 (134)) iOS mobile app.
  3. Make sure Obsidian uses the vim mode (in Editor, with the “:q!” answer).
  4. Open any document, in normal vim mode, so typically with a block cursor.
  5. Open the vim command line by typing “:” (column). It appears at the bottom of the screen (or just above the software keyboard, if using it).

Did you follow the troubleshooting guide? Yes

There is a post on a disappearing command menu, but this is a different issue.

Expected result

Obsidian mobile used to display the command line correctly (so in light letters on a dark background).

Actual result

Characters are written in black over black, which makes entering command extremely cumbersome.

Also, when using a software (i.e. non-hardware) keyboard, the command line overlaps the bar with the usual Obsidian buttons (previous file, next file, new file, tabs, menu).

Environment

(I can’t easily copy the info right now, so I’m typing some key information.)

iOS 17.5.1
Obsidian version: 1.5.12 (134)
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on