Vim menu doesn't show up

Steps to reproduce

I enable vim mode
I go to a page in edit mode
I press the key “:”
The vim menu appear and disappear immediately

Behavior expected

The vim menu doesn’t disappear

Environment

Tablet and Smartphone Android
Last version of Obsidian

Thanks

1 Like

Do you mean the command-line at the bottom where you enter commands?

Do you have Obsidian installed anywhere else, like on desktop where it does work? I am just wondering if this is Android-specific? Or if it can be narrowed down to your vault.

I tried on MacOS, iOS, and iPadOS and it’s working for me.

Can you please share your “Show Debug Info”?

Yes command line menu.

I tried with windows, it worked fine.

but it doesn’t seem to work on Android.

I have tried on a smartphone Pixel 7 with Android 14 on a fresh install with no extra addons
I have tried on a tablet Samsung s tab 9 with Android 14 with my vault with extra addons

Both doesnt work

I made a small video to show you buy it’s not authorized.

For debug I don’t know how to do .

Are you using a keyboard?

Can you post a screen recording of this nor working in a new vault?

Upload it somewhere and put the link here.

I went to reproduce this as I also had this issue where the little box to type commands would appear briefly and then disappear, but it now seems that the little box doesn’t appear at all.

Desired behavior:

  • When in a note with Vim mode enabled, pressing “:” opens a little prompt box along the bottom where I can type Vim editor commands like regexs, search, etc.

let me know if you still have this problem when you get Obsidian Mobile v1.6.2+

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.