Vault file says "location is not available" and can't be accessed after deleting it from vault selection menu

Hi everybody.

I am having a lot of trouble accessing the root folder for a vault I deleted from the vault selection menu through the “X” on the top-right part of the vault’s card. Ever since I have done this, I receive the message: C:\XX\XX\XX is not available. If the location is on this computer, verify if the device or unit is connected… The message can be seen next (though it is in Portuguese).

With this, I can’t copy, paste, change the folder’s name, or even delete it. However, when I access it through Obsidian, the program recognizes all files within.

Does anyone know what happened and how I can fix this?


  1. Where do you get that error message? In Windows file explorer?

  2. If you can still access the notes in Obsidian, open the 3-vertical-dots menu and select Show in system explorer. Does it open an explorer window? Is it the one you’re missing?

Hi @macedotavares

The answers to your question are:

  1. Yes. I receive this message in Windows File Explorer.

  2. I did what you suggested and selected “Show in System Explorer” but nothing happened.

Futhermore, I find it strange that I receive this message only for this folder and none else in my computer. I tried to check if I had any problems with my HD, any currupted file or something else, but no problem at all was found.

That is odd indeed.

So, just to make sure I got it straight:

  • You get that “Location Unavailable” error message when you try to access the vault folder on Windows.
  • You can access your notes through Obsidian, but it refuses to shown them in the system explorer.

If this is correct, I suspect something’s wrong with Windows itself, and not Obsidian. As a last troubleshooting step, have you tried searching for a known note name (like or something) in Windows search?

Other than that, I can only suggest you try these fixes, but without knowing the cause or the specifics of your system, it’s more of a hail Mary routine than a serious solution.

@LauroAJO Unfortunately, I don’t know how to help you.
When you remove a vault from Obsidian, we just remove it from our config files. We don’t touch the directory in any way.

I came here looking for an answer and am having the exact same problem.

Are you on Windows too?

I would suggest opening a #bug-reports with as much info on how to reproduce this as possible

The only thing that comes into my mind is if you used some weird character in the path and it is confusing windows.

Probably going to be the special character, I had the same issue using a fullstop on a folder name.

@jsunden do you still have this problem?

Do you have full control rights to this folder? (Properties/Security tab)

I ALSO came here looking for an answer because I also have the exact same problem.

As you can see I also use a full stop on my folder name, so maybe special characters are the problem here.

And I don’t even have full control rights to this folder

I see a period in your vault name. This character isn’t allowed in Obsidian file names.

I’m not sure what this could mean, or if it’s related or not. If you fix the period, this might still be a problem for you.

I’m having a similar kinda problem, but how do I remove the period? I’ve tried everything but nothing seems to work.

“nothing seems to work”. What do you mean? Are you getting an error or something? Where specifically are you getting stuck?

What is your OS?

You might have to view hidden folders.

  • MacOS hit Cmd-Shift-.
  • Windows go to View Options → Advanced → Show hidden files

Then just rename the folder…? (In your computer, not in Obsidian.) But if that fails, can you describe what happens?

The problem indeed seems to be the period at the end of the folder name (such as “Test V.” in the example above). Solved by renaming the folder in the obsidian vault. Now I can access the folder in the explorer aswell.

Okay, so I was having the same problem with my Obsidian vault folder, and as someone in replies suggested that windows does not allow a period [.] in their file name, I realized I had put a period and the moment I removed it the problem was solved.
You can remove the period through “Rename Vault” through Obsidian.