Using diacritics

Hello, all. I’ve run into an issue when using the transliteration for the retroflex “d” (i.e., ḍ) in my notes. Rather than appear as “ḍ” in my text, it disappears and deletes the following letter/symbol. This “ḍ” must also be a shortcut command–for what, I’m not sure as I just started using Obsidian an hour ago. Is there a way to bypass this command (or whatever it is) so that I get my “ḍ” back? I’m hoping to use this app to organize my notes for a book project. But I’d need access to diacritics since most of my notes will be transliterated from non-Roman scripts. FYI, I’m working on a 2020 Macbook Pro, Catalina OS.

You can customize Obsidian’s keyboard shortcuts. There’s a preference pane for that.

Found it. Thank you!

I spoke to soon. The Command + D shortcut–my shortcut to type “ḍ”–also happens to be Obsidian’s default shortcut for “delete paragraph.” I deleted the shortcut from the keyboard shortcuts preference pane, so that the shortcut for this command now reads “blank.” But the shortcut still deletes my paragraph instead of adding “ḍ”. I tried quitting the program and re-opening but to no avail. Any suggestions would be appreciated!

Hmm. And you don’t have this problem in other text editors?

What keyboard language are you using?

No problem in TextEditor or BBEdit. Also, the “ḍ” works in Obsidian’s search box, just not in the text editor itself. (btw. I’m using Obsidian v.0.10.13)

I use a keyboard layout called EasyUnicode. It looks like the developer’s web page is defunct. But the download can be found here under “Download EasyUnicode.”

I’ve placed the problem on hold by replacing the “ḍ” with a back-linked [[d]]" in my text, which I’ll be able to find and replace easily once the issue gets resolved. But obviously this is not a permanent fix :laughing:


@jmum this is of course annoying and hope there’s some easier way. I’m not sure if you have a special keyboard, or if you are using a series of modifier keys to access these characters.

As a workaround, (you might already be doing this, but if not I’lll mention it in case it’s useful) a text expander tool could help you out a lot.

Here’s the free one I use

With espanso set-up is a little bit tricky but worth it, if not there are many other paid alternatives that seem to work great.

Hope that helps

1 Like

I think you should file a bug report.

@santi @macedotavares Thanks for engaging with this issue! Since last checking this thread, I’ve tried creating a new keyboard shortcut for the “ḍ” in my Mac keyboard preferences. While the shortcut works in other text editors, it doesn’t work in Obsidian. With my limited knowledge on these things, I’m assuming then that using a text expander wouldn’t resolve the issue.

Another data point: while Command + D won’t give me “ḍ” in Obsidian, Command + Shift + D does give me the capitalized letter “Ḍ”. I’ll go ahead and file a bug report. Fingers crossed!

1 Like

Hey @jmum I think I know what it is.

I’m on Linux but I think it’s safe to assume that this is what’s causing it in Mac.

If you go to Obisidan Settings > Hotkeys > Delete Parragraph

This shortcut is causing conflicts for what you want to achieve.

All you need to do is press on the "x" to remove this default shortcut

Now it should work without any issues


I’m the worse I skipped and didn’t read the fact you already tried this

This should have worked, just in case, it’s worth trying to reload obsidian

to reload Obsidian do cmd + r

If that doesn’t work then it could be a bug for sure

Best of luck!

Thanks @santi ! Reloading Obsidian didn’t resolve the issue. But it’s good to know about cmd+r :grinning:

1 Like

you are welcome, sorry to hear it hasn’t worked yet, best of luck with it!

1 Like