URLs not clickable when property type is set to 'List' (was: @ in URL in YAML not parsed correctly)

Steps to reproduce

  1. create a YAML frontmatter property with a URL containing a @ symbol, for example:
youtube channel:
  - https: //www.youtube.com/@HeroicBrian

Did you follow the troubleshooting guide? [Y]

Expected result

When clicking the URL, the link should open in the browser

Actual result


Nothing happens when link is clicked.

Additional information

You need to include the debug info / environment for bug reports. Are you running v1.4+ ?

You have a space after https:. For me, if I remove the space it functions perfectly with or without an @ symbol.

1 Like

That’s weird. It is still not working…

That space is created by Obsidian when editing the YAML frontmatter in Source view… another bug?

Apologies, tested again in Sandbox and no problem. Apparently this is cause by a plugin… will check which one …

Obsidian version: v1.4.1
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:05 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6000 22.6.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Minimal v7.1.1
Snippets enabled: 7
Restricted mode: off
Plugins installed: 31
Plugins enabled: 30
1: Calendar v1.5.10
2: Dataview v0.5.56
3: Excalidraw v1.9.12
4: Note Refactor v1.7.1
5: Outliner v4.7.1
6: QuickAdd v1.2.1
7: Templater v1.16.0
8: Tracker v1.10.9
9: Advanced Tables v0.19.1
10: Sortable v0.3.1
11: Kanban v1.5.3
12: Style Settings v1.0.6
13: MetaEdit v1.8.0
14: Periodic Notes v0.0.17
15: Paste URL into selection v1.7.0
16: Carry-Forward v1.4.5
17: Tag Wrangler v0.5.11
18: Natural Language Dates v0.6.1
19: Metadata Menu v0.5.1
20: Obsidian42 - Strange New Worlds (SNW) v1.2.2
21: Commander v0.5.0
22: Plugin Update Tracker v1.5.1
23: Workspaces Plus v0.3.3
24: Text Generator v0.3.20
25: PodNotes v2.10.7
26: Contextual Typography v2.2.5
27: Longform v2.0.3
28: Remember cursor position v1.0.7
29: Importer v1.0.4
30: ExcaliBrain v0.2.5

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Found it! The problem is not caused by a community plugin, nor by the @ symbol. The problem is caused when the property type of set to ‘List’. A list of URLs can be entered, they are displayed correctly, but they cannot be clicked.

Fixed in 1.4.2

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.