Turn Off Autocorrection in Obsidian, MacOS Ventura

Why is Obsidian the only app I use that has the ability to turn off Apple’s system-wide autocorrection disabled. I want to disable autocorrection because it sucks, but the Obsidian edit menu has no Spelling and Grammar submenu where the “turn off autocrrection” feature is normally located.

Autocorrect is still an open feature request in Obsidian. I have never seen system-level autocorrect work inside an Obsidian vault on a Mac. I would love to know if it is possible to turn it on.

You misread my issue … autocorrect is on, I can’t turn it off! The toggle that every other MacOS app has is missing … there is no way to stop it from putting commas everywhere when I am dictating into it.

1 Like

Oh, I understood it, and I wanted to know how to turn it on because so far Obsidian has never had access to the system-level autocorrect options offered by macOS.

I see now that you are talking about auto-punctuation in dictation in Ventura. You can turn that off:

Note: Dictation automatically inserts commas, full stops and question marks for you as you dictate. To turn if off, choose Apple menu > System Settings, then click Keyboard in the sidebar. (You may need to scroll down.) Go to Dictation on the right, then turn off Auto-punctuation.

Yeah … that doesn’t work anymore, it’s not in system settings in Ventura. They moved it to the edit menu for each individual app. They all have it now, except for Obsidian.

Screenshot 2022-12-04 at 11.29.06 AM
This in on Ventura. Keyboard is all the way down on the bottom of System Settings

1 Like

Thanks for the screenshot, @BarryPorter13.

Auto-punctuation for dictation is new in Ventura, so it has to be there.

Autocorrect for spelling errors has long been in macOS and switchable in most apps, but not as yet in Obsidian.

Yeah, I’m running Ventura 13.0.1 and it’s not there …

Try clicking the button “Set Up Keyboard…” and see if it makes the choice show up.

It should be there…

Barry

In macOS Ventura, the global setting for Autocorrection are found under System Settings > Keyboard > Text Input > Edit.

Obsidian is an Electron app, which means that some system settings don’t apply. Apparently, this includes the option to turn off autocorrection for Obsidian.

1 Like

This is what I thought may be happening … thanks! ;-(

FOR OTHER USERS WITH macOS DICTATION (not autocorrect) PROBLEMS:


Autocorrect and auto-punctuation for dictation are discrete entities.

Autocorrect is a longstanding feature of macOS and iOS, correcting mistyped words. Autocorrect is not available in Obsidian (at the time of writing this post). Other apps are able to toggle it off and on.

Auto-punctuation for dictation is new to Ventura and iOS 16, with the OS automatically adding punctuation to dictated text without the user having to give specific punctuation commands. (It seems to be rather wayward in actual use.) Auto-punctuation for dictation is available in Obsidian.

Auto-punctuation for dictation is only available as a system-wide setting, but it appears that some users don’t see the option shown in screenshot above by @BarryPorter13.

This appears to be related to the microphone settings that are in use.

Why Is Auto Punctuation Missing On My Mac?
The Punctuation feature can be considered as the Hardware Dependency aspect. Currently, it can be only on Apple Mac devices with a built-in microphone.

Auto-Punctuation in Ventura — DOES NOT EXIST — How to disable?

So perhaps a change in the microphone setting will resolve this issue for the OP. As it is, this appears to be an issue for Apple, not Obsidian.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.