'Translucent window' setting results in increasingly laggy window drag movements as mouse polling frequency increases

The issue is still present in the latest release of Obsidian, v0.10.13 (Installer version v0.10.7). This was recorded on Windows 10 Pro 20H2 19042.746 on an RTX 2080 GPU running driver version 461.09, on an Intel i9-9900K, on a 144 Hz G-Sync (disabled) display.

I thought it might be worth noting, as a potential indication of where the issue might stem from, that the VSCode-Vibrancy extension for Visual Studio Code, which adds the same ‘acrylic material’ transparency effect found in the Fluent Design API, causes it to lag in the same way for me. Terminal, another app that features the same transparency effect (?), however, doesn’t lag when it’s enabled. What is the difference between the two implementations, and why do some experience this issue and not others? Is Obsidian leveraging the ‘acrylic material’ effect, or something similar but different?

Happening for me on M1 MacBook Air.

Steps to reproduce

turn on translucent window

Expected result

translucent window

Actual result



  • Operating system: win 10
  • Obsidian version: 0.11.3

Additional information

Close your transparent effect in the Color setting of windows should fix this issue.

1 Like

I think this function is useless, but bug is bug

Same issue present with v0.11.13

Really enjoy this function as I can see my lovely wallpaper when studying…please fix the bug :woozy_face:

1 Like

Update: the issue is still present in v0.12.3 on Electron 12.


using electron window plugin can make translucent without lag. Just adjust opacity in plugin setting, and not turn on translucent window core plugin.


I have the same problem. In window 10 version 1909, rtx2060 + AMD ryzen 5 3600 6-core processor, the Obsidian version is 0.12.12

To everyone who was effected by this, it is fixed in Windows 11. I just noticed now!

1 Like

Just visit this topic to share this FIRST!!! But damn!! :grin:

1 Like

Windows 10 Pro - Dell XPS 15 9500
Obsidian Version 0.13.14

Issue just occured for me, though this setting has been enabled for some time.

Steps taken:

  • Connect additional display to laptop (both screens 1920x1080 resolution)
  • Additional monitor supports 4K

Issue occurs following connection to additional 4K monitor.

Issue re-occurs whenever translucent window is enabled in Obsidian.

Issue resolved by disabling translucent window settings.

v0.13.23 still same. Win 10.
Electron window plugin can’t replicate the frosting glass/blur effect.
Please fix this :pray:

Confirmed on Win10 21H2 19044.1526
AMD 5950x
Obsidian 0.13.23

Download and reinstall obsidian from the website. The new version might solve this issue.

Still have the issue on v0.13.31

Windows 10 Home version 10.0.19044 Build 19044
Intel i7-10875H
Nvidia GeForce GTX 1660 Ti

Ok, I just confirmed that this is windows bug. It should be fixed in win 11.

I’m experiencing this on 1.0.3, installer v1.0.3, Windows 10 Education 22H2, Intel HD Graphics 4000. I do see that I have a .NET update (probably not relevant) and a Windows update (maybe relevant since it mentions a couple direct3d fixes, but I’m not that hopeful) still to install, so I’ll add to those and report back if they do fix anything. But Windows 11 isn’t an option on this machine. I’ll probably just disable Obsidian’s translucency effect on all but my Win 11 tablet … which doesn’t really have enough memory to run Obsidian smoothly.

I have one [email protected] display and one [email protected] on this machine. I can switch the first one to 30.011Hz, which doesn’t help. It does seem, however, that disabling one of the monitors decreases, but does not eliminate the lag; more so if it’s the larger screen that I disable. So maybe that’s a useful insight.

Toggling Hardware acceleration in Settings>About also did not help.

Also, I think this may be a regression from 1.0.0. That is, when I booted Obsidian this morning (1.0.0 installer, v1.0.0), I don’t think it had this issue, but then it auto-updated to 1.0.3 and the problem began. Switching to 1.0.3 installer v1.0.3 didn’t help.

Also, since the issue is apparently caused by a mouse polling rate significantly faster than the screen refresh rate, it may be relevant that my mouse is a Dell MS116t. According to this testing site, it seems to target a mouse polling rate of about 125Hz. Since this is a basic office mouse, I haven’t yet found a way to modify this, but others with fancy gaming mice might try reducing their rate.

Update: No dragging problem on my home PC:

  • v1.0.3, installer v0.15.9
  • Windows 10 22H2; just updated last night.
  • i7-4770K/GTX 1080
  • Hardware accel turned on
  • Transparency effects turned on in Windows Settings > Colors

I guess the newer installer brought the regression with it.

Update 2022-11-23: (27 days later): Also, FWIW, the new Windows terminal doesn’t have this problem on the machine if I set it to use acrylic for both the tab bar and the main area (although it refuses to use transparency when not the focused window). I tried the vibrancy vscode plugin mentioned by @Roundlay above, and it does have the lag. So, I guess it’s an electron thing. Currently on v1.0.3 installer v1.0.3 still; we’ll see if it improves with the 1.0.4 installer that @WhiteNoise suggests will be out soonish.

1 Like