Transclusion with double vertical lines

I’m using transclusions and don’t understand why they appear with a double vertical line on the left and put all the content of the document I’m referencing.

I know that we can use reference to a specific section or even to a block, but the problem is that by default ( ![[]]) appears all the content.

Here you can see an example:

Can someone help me with this?

That would be caused by whatever theme (or extra CSS) you are using. Try looking in Style Settings for your theme to see if there are any options that you can change. Using a different theme or a CSS snippet to alter the embed lines would also take care of it.

1 Like

Hi @ariehen I couldn’t find a way to change this. I’m not using any CSS snippets. Do you know which is the correct way to uninstall completely Obsidian from the Mac? I uninstalled it several times to start from scratch but always has the same configuration.

I followed the following suggestions but I couldn’t uninstall Obsidian successfully: Uninstalling Obsidian on MacOS

There is no reason to uninstall. This is 99% likely coming from the theme you are using. Settings > Appearance > Themes, and choose the default theme or another that looks good to you. :sunglasses:

1 Like

Yes, but the problem is that is showing me the total content of the transclusion. Before, when I started using Obsidian, I was able to scroll to show only one part of the transclusion. Now, when I use a transclusion it shows me the total content of a document.

Do you know why?

To link to specific headings it would be ![[My note#Heading 1#Heading 2]] and to link to blocks it would be ![[My note#^37066d]]

Perhaps that’s what you are looking for?

Sorry, I was focused on the double bar issue. :smiling_face:

Sorry, I think that I’m not explaining very well my issue. Can you see the following video at 1:51 m?
In that video, that person is using transclusion with scroll. I would like to be able to use scroll in the transclusion.

I don’t know what happened that I’m not able to use scroll anymore.

I found a solution. I started using the snippet.css with the following code:

.markdown-preview-view span.internal-embed .markdown-preview-view,
.markdown-preview-view span.internal-embed .markdown-embed-content {
  max-height: 300px;

That’s all. :slightly_smiling_face:

Thanks for your time @ariehen!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.