Three hyphens after one another no longer makes horizontal rule

What I’m trying to do

I’ve using Obsidian (mostly on my iPhone) for about half a year now, and making horizontal rules have worked just fine when typing three hyphens in a row: “—” (without space between) / “- - -” (with space between).

But suddenly, today, when I woke up, and was going to proceed on the daily note I had begun on the night before (after twelve), to my despair, I found out that this no longer worked. Now it looks like this: —-. I know it’s because of the “smart punctuation” function on the iOS, so what I’m wondering about is why it worked in the first place?

Before, when I pressed the first hyphen, it started to sort of “mark the whole line” automatically (in lack of a better description), so the smart punctuation function was turned off.

I know I can just turn off “Smart Punctuation”, and maybe I’ll do it if that’s the only solution (except for tapping “123” (like “signs” button), then “-”, then “space”, then “123” again, then “-”, then “space”, then “123”, then “-”, and then “return” on the iPhone keyboard), but since it worked before, shouldn’t it be another solution to solve the problem?

I hope some of you can answer, and I’ll be very regardless of whether you have a solution or not.

This is the first time I’ve created a new Topic on the forum. I’d be happy to know if I could have written this in a way that is better for the community.

Have you done an iOS update or Obsidian update in the last 24~48 hours? Anything you can think of that’s changed (besides the hyphen behavior)? I’ve had “Smart Punctuation” off for a while, so I can’t be of any help there.

There are alternatives to the --- though:

* * *
- - -
_ _ _
1 Like

I don’t know why it worked before — I don’t think that’s ever worked for me unless I turned Smart Punctuation off (I wish iOS had separate settings for quotes and dashes lice MacOS does).