Theme: Shimmering Focus

It has recently come to my attention, that new themes are usually showcased in the forum (:wave: @DEV_Scribbles ). And in fact, I noticed that I have never shared my theme here, even though it’s about half a year since I submitted it to the theme store :see_no_evil:

So well, better late than never, I guess? :sweat_smile:


Here is Shimmering Focus, a minimalistic theme focused on condensed information display. I am proud to say that is also the first and only theme with a full-blown documentation site for all it’s features, which I recommend to check out, since everything from design principles and advanced features is explained there.
:arrow_right: Documentation

I also strongly recommend to use it with the style settings, which unlock various features, and also the ability to re-enable hidden elements.
:arrow_right: Style Settings

9 Likes

a stellar theme and an even more stellar creator! thanks for all your work!

1 Like

It’s amazing how every snippet I love happens to be included in this theme. Ever since I tried it, I can never switch to another theme, always thinking 'meh I miss this or that from SF’ and go back.

1 Like

I’m a huge fan of this theme. There is one UI element that is causing issues – this blue ‘X’ that appears over the text of links to pages which have not been created yet. Does anyone know how to move it out of the way, or eliminate it altogether?

image

You can disable it, in style settings, under gutter and active linedisable unresolved links indicator

ah, that one is actually a bug that made it into the theme in one of the recent updates. I’ve fixed in in the latest update. The Indicators are supposed to look like this:

1 Like

I just updated the theme, but I’m still seeing the issue :thinking:. Just to clarify, it looks like it’s working correctly in preview mode, but the issue persists in edit mode.

I’ll disable it now per @imed 's suggestion, and try it again later. Thanks!

ah, didn’t notice that the issue also exists in Live Preview. fixed in the latest update :slight_smile:

1 Like

I love this theme — but something seems to have gone haywire. All background colors seem to have gone transparent. This is what happens when I open the settings panel:

Other themes are fine. (Edit: I have deleted and reinstalled the theme, updated plugins, etc.) Any suggestions?

Hi, I think that happens when the style settings data has been somehow corrupted. If that is the case, even re-installing the theme won’t help, since the style settings are still preserved in the data of the style settings plugin.

Could you try deleting the file {your-vault}/.obsidian/plugins/obsidian-style-settings/data.json, and then restart Obsidian? If I am right, this should fix things.