Theme: Blue Topaz

Thanks for a great theme. I have been using it for a long time.

With the plugin Style Settings I have now selected the Honey milk color palette. Is there a way to change the color of the line highlighting for the cursor with Style Settings?

Ignore me! Found it in 2.3 Element Styles (Mute Active Line).

1 Like

Hi @whyI ! This is my beloved theme. Thank you so much from always implementing "shining useful things " into this theme.

I would like to have more options on the checkboxes icons because it become very useful to my workflow. Maybe could show us how to add an snippet?

This is the list of checkboxes icons I would like to have (copied from minimum/sanctum/primary themes):

Syntax Description
- [ ] to-do
- [/] incomplete
- [x] done
- [-] canceled
- [>] forwarded
- [<] scheduling
- [?] question
- [!] important
- [*] star
- ["] quote
- [l] location
- [b] bookmark
- [i] information
- [S] savings
- [I] idea
- [p] pros
- [c] cons
- [f] fire
- [k] key
- [w] win
- [u] up
- [d] down

here an image of it:

What do you think? Can you add those checkboxes to BlueTopaz or can you provide a basic snippet so I can set it up there?

Again, thank you soooo much for this wonderful theme!


Thanks for creating the best-looking obsidian theme. In light mode, no other theme comes close. I am having one issue that is driving me crazy. The cursor when I type seems to move back or lag before moving forward. I’ve tested about 15 different themes and this is the only one where the cursor behaves like that. Is that a feature of the theme? If so, is there a way for me to turn that off? If it’s not a feature of the theme are there any known causes that would make the cursor behave like that?

I went into style settings under 2.3 element styles and turned on Mute Active Line (wasn’t sure what that does) but that didn’t fix it.

I’m loving the theme except for this one… issue/feature?

When I was setting the theme up I turned on Fancy Cursor and turned it off but didn’t click reset to default. Going back into settings and clicking reset to default on Fancy Cursor got rid of it.

I was going to just delete this post but thought it would be better to reply in case someone in the future makes the same oversight I did.

1 Like

This is very nice theme and I’ve been using it for a while. The only issue I have is with the comment color (green!). It’s too distracting for comments. Anyway I can change the color to something grayish? @whyI

Hi Jopp,

I adjusted the theme code, so I am not sure whether I caused your problem.:joy:

You may remove the background image and change the title bar color by Style Settings shown below. Have fun!

Hi LadyRuthven,

Thank you for liking Blue Topaz! We have also received some feature requests about increasing more types of checkbox icons. We may add them to the theme shortly after finishing some new features and bug fixes.

Spoiler: We are now working on Dataview supporting and providing some color palettes for code syntax highlighting.

1 Like

The feature is ineffective in the Obsidian version above 0.14.9. So please never mind. And I have replaced Fancy Cursor with a new option, Rainbow Cursor.

Thank you for liking the theme.

As the spoiler above, we are working on code syntax highlighting, so please stay tuned!

Thanks very much. I’ll wait then.

Since you are responsive, I do have another question/request: is there a way to change or disable the background images on the main and sliding panes? It would also be very nice to have that option as well.

Hi. I found this odd issue with paragraph line breaks when it is a part of a bullet or numbered list.

When the theme is Blue Topaz

When the theme is the Obsidian default

I’ve tried turning off all the plugins I have, making sure that there is no custom CSS. The problem persists.

Do you know what might be causing this issue?

1 Like

I am also facing the same problem, did you find the solution for this?

Hi. I have a question. Ist it possible to turn off/change the loading animation? I played around with “Style Settings/2.3.16 Loading Page” but it does not change anything.

Style Settings → 2.3.16 Loading Page → Loading Page Style

That’s what I did … no effect. All other settings work fine, but this one does not change anything. It’s weird.

I just found that Style settings → 2.3.2 List → List Style Bracket 1 does not break lines on words. It will however show brackets.
The other option Rainbow lines work best - No line break and no brackets. so for now I found a solution.

1 Like

It seems I was too quick to declare that it (Style settings → 2.3.2 List → settings ) worked. It is back to broken words with all settings. I moved on and started using Minimal theme.

1 Like

@clever-s-pkm @nhivn @netfly
Sorry, guys. I can only express my helplessness for the issues you mentioned if you don’t want to update the theme.


Right … after the update it works :wink: