Templater Shortcut Works on Korean Language Setting on a Mac

Hello, I’ve been trying to use hotkeys for Templater community plugins and it isn’t working properly.

For Templater, the hotkey option+E works only when the language is set to Korean. I’ve looked up ways to resolve the issue and surprisingly it’s an issue on the Windows side. But I’m currently using a Mac (M1 Chip if that matters). And the issue happens when it’s NOT set to English.