Tasks plugin says 'loading tasks...' after latest update

Things I have tried

  1. Updated the plugin
  2. Disabled and re-enabled the plugin
  3. Uninstalled and reinstalled the plugin
  4. Tried eliminating lines of code one at a time - no change

What I’m trying to do

I’m a newbie and probably missing some fundamental concept. Thanks in advance for any/all help!

Before the 1.0.3 (I was not on 1.0 yet), I was using the tasks plugin and it worked brilliantly. I did not set a global filter. All checklists were turned into tasks. I created a note called “Tasks Plugin” and put the following code block in it:

\``` tasks
not done
path does not include reading
short mode

(Backslashes included for escaping in the help forum). I have a reading list page that I didn’t want to be included in the tasks list.

After the update, the page just says “Loading tasks…” and never changes. I’ve updated, checked help files, etc. I’m confident it’s user error, just not sure what else to try.

Did you try restarting Obsidian? I see this on mobile every once in a while, a restart of the app typically works best for me.

I did try that, multiple times. No joy.


So, I tried to move my vault from one location to another and it kept getting nondescript errors from my Mac (the files were on OneDrive). I went file by file through the vault and eventually found two files, side by side, where something was not right (something weird with syncing up to OneDrive and back). I couldn’t copy them or move them. I went into Obsidian and they were just a title on an empty note I think. Anyway, I vaguely remember them and knew they wouldn’t be that important. I exited Obsidian and deleted the two files from the file system. I wasn’t even thinking about tasks at the time.

As soon as I got back into the vault, tasks was working again!

Bottom line, some kind of corrupt files was keeping the tasks plugin from reading all the files (I’m guessing)? Would be great to have some sort of failure message when that happens, but that might not be possible.

I made a few test task view notes and I’m also quite pleased that they all work great - apparently I do know what I’m doing (at least a bit).


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.