Tables don't play nicely with vim mode

Steps to reproduce

A few unexpected behaviours or issues with vim mod and tables:

  • On a table with 1 line per row, pressing 5j does not in fact go down 5 rows. It goes down 5 rows in the cell that it’s in, and then jumps down 1 row.
  • When scrolling through a document with <C-d> and <C-u>, passing a table messes up the whole scrolling flow. If you end up with the cursor inside of the table, then you have to hit a <C-d> or <C-u> to scroll down/up one row at a time. This is very annoying.
  • In a cell which has lines wrapped, I can not for example move down a visual line with gj. Have to scroll “to the right” until I get to the next visual line in the cell.
  • Every cell is its own “document” so it has its own line numbers, which doesn’t make a lot of sense. When displaying line numbers, now I’m on “line 1” wherever I am at in the table. With relative line numbers this is especially painful, I can see that I am 7 lines into the table, but I can not jump 7 lines up. (This is when using the relative line numbers plugin – in the sandbox vault it doesn’t show a line number inside of the cell – maybe that’s a bug I should report on the relative line numbers repo).

Did you follow the troubleshooting guide? [Y]

:white_check_mark: I checked every bug in the Sanbox vault.


	Obsidian version: v1.6.5
	Installer version: v1.4.14
	Operating system: Darwin Kernel Version 23.5.0: Wed May  1 20:14:38 PDT 2024; root:xnu-10063.121.3~5/RELEASE_ARM64_T6020 23.5.0
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Base theme: dark
	Community theme: Obsidian Nord v0.2.0
	Snippets enabled: 1
	Restricted mode: off
	Plugins installed: 11
	Plugins enabled: 8
		1: Vimrc Support v0.9.0
		2: Heading Shifter v1.5.1
		3: Relative Line Numbers v3.0.0
		4: Emoji Shortcodes v2.2.0
		5: Local Backup v0.1.7
		6: List Callouts v1.2.7
		7: Linter v1.24.0
		8: WakaTime Laurens v1.0.2

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Thank you Obsidian team!!! You’re all LEGENDS.

Some of those things are design decision and are unlikely to change.

Anyway, you can post your suggestions here: