Table renders in editing mode (live preview) but not reading mode

Steps to reproduce

The following markdown:

question words:
| eng | fr |
| - | - | 
| who | qui|
| when | quand |
| what | que |
 | where | où |
 | why | pourquoi |
 | how | comment |
 | how much | combien |

Expected result

Table should also render in reading mode.

Actual result

Editing mode (when moving cursor out) (expected behavior):

Reading mode → table should also render here

Environment

  • Operating system: Ubuntu
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.14.6
    Installer version: v0.13.31
    Operating system: #49~20.04.1-Ubuntu SMP Wed May 18 18:44:28 UTC 2022 5.13.0-44-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: on

RECOMMENDATIONS:
none

1 Like

Put a space between the question words: and the first row of your table.

question words:

| eng | fr |
| - | - | 
| who | qui|
| when | quand |
| what | que |
 | where | où |
 | why | pourquoi |
 | how | comment |
 | how much | combien |

Yes, I know how to fix it, but shouldn’t preview mode and reading mode be consistent? Maybe I should phrase the bug report differently…

1 Like

Steps to reproduce

  • Write a line of text
  • Make a table directly below the line with text
  • See table appear in live mode
  • Export to PDF
  • Table is exported as raw text in PDF

Expected result

  • Operating system: Manjaro, kernel 5.19
  • Debug info:
SYSTEM INFO:
	Obsidian version: v0.15.9
	Installer version: v0.15.9
	Operating system: #1 SMP PREEMPT_DYNAMIC Mon Sep 5 10:16:57 UTC 2022 5.19.7-1-MANJARO
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Obsidianite
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 4
	Plugins enabled: 4
		1: LanguageTool Integration v0.3.0
		2: Advanced Tables v0.17.3
		3: Meld Calc v1.0.2
		4: Paste image rename v1.5.0

RECOMMENDATIONS:
	Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Example.md (232 Bytes)