Table Header rendering issues

Steps to reproduce

Create table:

dtx pcr bfd
dtx PCR-1 BFD-1
sdf sdf sdf

Expected result

Markdown table header formatting (as above)

Actual result

Headers are regular font (actually render smaller than cell values)


Debug info:

Obsidian version: v1.0.3
Installer version: v1.0.3
Operating system: Windows 10 Pro 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

  • This post appears related to same issue, but didn’t see a resolution
  • Consulted This post, and AFAIK I am using the hyphen-minus in the header divider (have tried both keys on keyboard with same result.
  • Tried in Obsidian sandbox vault and get same result
1 Like


If you’d like to change the style, you can use the following snippet:

body {
	--table-header-size: var(--font-text-size);
	--table-header-weight: var(--bold-weight);
	--table-header-color: var(--text-normal);
1 Like

Thank you.
I used this to fix the fact that table headers were in gray on white background in notes exported as PDF.