Sudden Black screen in one obsidian vault

Things I have tried

I tried reading all the posts about black screens. None really were helpful, perhaps becasue I’m pretty new to Obsidian (1 month appx).

I searched all the possible comments in the Forum and did move the screen around as was suggested but nothing gave me any changes to the pure black screen. No commands are visible.

I looked into saved obsidian files in dropbox and on my computer and everything appears to still be there, except everything that i input into this Obsidian vault/files cannot seem to be accessed. Thanks for any assistance.

What I’m trying to do

I searched all the possible comments in the Forum and did move the screen around as was suggested but nothing gave me any changes to the pure black screen. No commands are visible.

I looked into saved obsidian files in dropbox and on my computer and everything appears to still be there, except everything that i input into this Obsidian vault/files cannot seem to be accessed. Thanks for any assistance.

What I’m trying to do

1 Like

“Show debug info” - Are you able to run this command and share the results?

Are you able to access your preferences?

Do you have the Sliding Panes plugin/theme? I understand it was causing some conflicts in recent versions. If possible, try disabling that.

Otherwise, we really need to have more info before we can help. “Show debug info” if you can. Otherwise, list more info:

  • Operating system
  • Version number (and installer version)
  • Plugins installed
  • Theme

Or a screenshot perhaps.

Hi @rigmarole, I also have this bug and will try to do my best in giving any relevant info.


I have a couple nested Vaults (knowing full well the risks that come with this, :sweat_smile: but setting different themes serve as context cues to switch mindsets). However, the frequent black screen only happens in my main vault, but not in my 2 nested vaults (which are mutually exclusive from one another; one for focusing on work, one for idea development/generation/writing).

The main vault is very plugin heavy (at least 20 plugins at this point), and I have a dedicated GPU that is likely being used for hardware acceleration. With that said, here are the specs:



Device name Dell G7 7700
Processor Intel(R) Core™ i7-10750H CPU @ 2.60GHz 2.59 GHz
Installed RAM 16.0 GB (15.8 GB usable)
Device ID CFA00D74-312E-4397-A8D1-C5E26FA788FA
Product ID 00325-82037-99374-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display


Edition Windows 11 Home
Version 22H2
Installed on ‎11/‎11/‎2022
OS build 22621.819
Experience Windows Feature Experience Pack 1000.22636.1000.0

Debug info


  • Obsidian version: v1.0.3

  • Installer version: v1.0.3

  • Operating system: Windows 10 Home 10.0.22621

  • Login status: not logged in

  • Insider build toggle: off

  • Live preview: on

  • Legacy editor: off

  • Base theme: dark

  • Community theme: none

  • Snippets enabled: 0

  • Restricted mode: off

  • Plugins installed: 20

  • Plugins enabled: 20

      1: Recent Files v1.3.3
      2: Editor Syntax Highlight v0.1.3
      3: Excalidraw v1.7.27
      4: Checklist v2.2.10
      5: CSV Table v1.2.0
      6: Natural Language Dates v0.6.1
      7: Spaced Repetition v1.8.0
      8: Citations v0.4.5
      9: Kanban v1.5.1
      10: Dataview v0.5.47
      11: MetaEdit v1.7.2
      12: Contextual Typography v2.2.4
      13: QuickAdd v0.5.5
      14: Excel to Markdown Table v0.4.0
      15: v0.1.19
      16: Obsidian_to_Anki v3.4.1
      17: Book Search v0.5.8
      18: Templater v1.16.0
      19: Obsidian Git v2.10.1
      20: Tasks v1.18.1

Concluding remarks

I’ve followed the instructions and updated all the plugins. I’ll reply back if it continues to happen in the Sandbox Vault or if it happens while community plugins are off. :+1:

I think I just hit this same issue but didn’t think of getting any debug info, so not sure this will be much help sorry.

But I suddenly got a black screen while typing, closed Obsidian, and then when I restarted Obsidian, my entire file I was editing was gone and wiped to an empty file. That was pretty scary, but I was able to recover part of my work with Dropbox. (Without Dropbox, there are also Obsidian snapshots for backups.)

Obsidian 1.0.3, Windows 10, default plugins, 1 community plugin (native scrollbars).

I’ve been getting a black screen recently: obsidian starts slowing down/lagging for 5-10 sec, then blackscreens. Data loss is only for that short period of lag. Happening once every few hours during continuous use.

Not sure it is causal, but every time it’s happened, I’ve been working on a note that’s simultaneously open in 2 different panes.

Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: Windows 10 Pro 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: light
Community theme: Minimal v6.2.0
Snippets enabled: 2
Restricted mode: off
Plugins installed: 8
Plugins enabled: 5
1: Minimal Theme Settings v6.2.0
2: Hider v1.2.4
3: Style Settings v0.4.12
4: Settings Search v1.2.0
5: Contextual Typography v2.2.4

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I can add more info:

  • it only happens when I’m editing a note that’s open in more than 1 pane
  • lag begins to happen when I’m actively typing or editing text. If I stop and wait a few seconds, it goes away and does not black screen. It only black screens if I keep going when it starts to lag.

if there is a helpful log I can post, let me know.


Few more data points:

  • I disabled all community plugins in my vault and went back to the default theme - still happening.
  • it usually only happens after the program has been running for at least a couple hours.
  • the note I’m working on in 2 panes is 80k+ words with hundreds of links (most to blocks) - large size possibly related?

Edit 2/22/2023: I am continuing to get approx 1 black screen crash per hour. Lately it’s been happening without any slowdown as a warning sign. It’s definitely connected to having the same note open in multiple panes, though.

Edit 3/1/2023: I am getting the same thing in a different large (180k) note. Black screening once per 30-60min when the note is open in 2 panes simultaneously.

I found myself here after installing Obisidian onto a new machine. I was getting the black screen while indexing. I resolved it by deleting the .obsidian folder that I copied over from old machine and re-copied it back again into the vault and it worked without the black screen.

Hopefully, anyone with this issue can get it resolved with this simple fix.

1 Like

Several times a day, I encounter a frustrating issue where the entire Obsidian window goes black. I have not been able to identify any specific cause for this problem, which occurs when I’m simply editing notes. Interestingly, the length of the note doesn’t seem to matter in my case (even notes with less than 1000 words are affected). Additionally, this issue is theme-independent, so it doesn’t appear to be related to my current theme.

I have over 100 plugins installed, but I haven’t been able to pinpoint a specific plugin that could be causing the issue. To make matters worse, the bug appears to be random and I haven’t been able to reproduce it consistently. This has made it challenging for me to troubleshoot and resolve the problem.

@Lennart Do you have the same note open in 2+ panes at once (e.g., to simultaneously work on different areas in the same note)? For me, that appears to be the cause.

@Lennart pinging you again, if we can get more data, bigger chance this actually gets fixed

This blackout of the screen seems to have gone away after v1.1.16 – I’m about to update to 1.2.8 on my Ubuntu box. Windows 10 is already past 1.1.16 without the black screen.

1 Like

I’ve been having this problem for the past year or so. I’m currently on 1.3.5 on Windows 11 and the same thing happens on my macbook though at different times.

When it started happening in the past it was whenever the notes reached a certain length (I did not have the same note open in two panes). On my desktop in windows that was around 25k words. The note would lag a bit as I was typing then the screen would go black and I just had to restart the app. On my macbook this was at around 80k words.

VERY RARELY, about 5 times total over the last year, the crash would result in the note I had been working on to go completely blank. This caused me to set the file snapshots at 1 minute so I never lost much but I ended up using that feature a lot more than I would have liked to have had to.

Now, it happens at 40k on my windows desktop (haven’t used the macbook in a while so not sure) and it happens frequently (once every couple hours) with far less words when I have the same note open in two panes (Only started doing this recently). I wound up here trying to find a solution and now that I know I can just not have a note open twice at once, I will simply avoid doing that.

I can’t run any commands when it does this or even open the developer console either. Ram is sitting at around 2-4 GB used when it happens, if that helps. I have tried disabling all my extensions but it still happens.

Just offering this up because it’s still happening to me so maybe others are experiencing it as well and this probably shouldn’t be closed just yet.

It seems some users still use old versions of Obsidian, this in combination with updated plugins might cause issues, eventually older versions of Obsidian are less robust too if dealing with larger vaults. Just my two coins.

To update Obsidian, download a new copy from Download - Obsidian

  • don’t use the build-in updater.

I am updating obsidian using a package management software (chocolatey), which actually installs the new version without built-in updater and also updates both Obsidian and Obsidian installer. The problem still persists.

Maybe an incompatibility with Electron (Obsidians framework)

Did you guys check if this problem persists with older versions of Obsidian as well?
If no, which version works for you normally?

always use the sandbox vault to trouble shoot issues.

I have since updated and am still having this issue (on every version I’ve used so far as far as I remember). Unfortunately the issue is intermittent enough that I would likely have to spend hours mindlessly typing to reproduce it in the sandbox vault. Typing into a file of 32k words was my most recent black screen. I have been using obsidian for 2 years now and don’t remember it ever not happening. (I’ve gotten to the point where I just make a new file when it happens so I have a log of it happening for about a year now).

It is more infrequent now too and maybe this is just placebo, but it seems to happen shortly after I switch desktops in windows (windows + tab, windows + ctrl + arrow) but I do that often enough that I can’t be sure.

I realize it is difficult to diagnose issues like this, I just wanted to mention that it is still happening to me, though it does seem less frequent.

1 Like

Hard to work this way.
Let me understand, this issue happens with obsidian only?
Otherwise it may be related to your graphic card. Alt-tab under windows (especially in fullscreen mode ) is not flawless.
The best you can do is to backup your obsidian vault folder, delete obsidian and re install a fresh copy.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.