Stuck on Loading cache

Not sure if you have found a solution yet. I had the same problem after being a little bit too wild with moving things around. Obsidian was installed through flatpak. Flatpak keeps around cache files even if you uninstall Obsidian. Therefore, just uninstall obsidian then delete the cache and config files that flatpak creates for obsidian. Success looks like the reinstalled obsidian asking to open a fresh vault. When I say delete things this does not mean delete the markdown files that are part of the vault, these are the files you want to keep!


I’ve been noticing this issue as well. The app takes a longer time to start up. I hate having to constantly troubleshoot Obsidian, I wish the app would just work the way it’s supposed to. Using Mac and Obsidian sync.

1 Like

Same issue

Same issue as well. Tried uninstalling and reinstalling Obsidian but the issue persisted… Any recommendations?

same 'o…
Followed this thread and activated Debug startup time.
I found 2 plugins, which I had deactivated already but stil they seem to slow down statup dramatically:


After deleting them, loading was MUCH faster …

at first… but once I restartet Obsidian again, loading took way over 10 minutes again. Normally It’s finished after 2 min.

They whole bootup time is much longr than displayed in the analysis. Like many others posted already, loading the cache is taking really long. Its about 95% of the whole startup time.
I also see a reaindexing task ever time I open obsidian again.

This behaviour is quite new and it wasn´t that way 1 day ago. I gues it´s connected to an update or so. I´m also on the latest release 1.0.3 and Obsidian is running on an up-to-date windows 11 64bit (not arm64).

Same here. Not sure what’s gone wrong

Yes, I’m getting this too on Windows 10.

Are you using Obsidian Sync? The notes are indexing every time I open Obsidian on Mac or iOS. I don’t have many notes (under 1000) but the app takes a long time to open.

Yes, I’m using Obsidian sync. Can that be causing it. I did find though that some plugins also seem to be playing a role. The app opened fine in restricted mode.

It’s working fine for me now. No idea what was causing it.

1 Like

I am having the same issue on Windows 11 and have tried everything from fresh intall to activitating and deactivating all plug ins and nothing sticks.

I am on Win10 and Obsidian no longer opens. Gets stuck on “loading cache.” In the past, if I reinstalled or open and closed a few times, it would eventually open. Now it doesn’t open at all. I have it trying to open the background and let it run for a few days to see what happens. I am currently using iA writer to navigate my vault. I hope this gets fixed at some point.

Solution on MacOS, possibly useful on Windows/Linux

I was able to clear out the cache by

  1. Exiting Obsidian ← important
  2. going to the ~/Library/Application\ Support/obsidian/Cache/Cache_Data directory and remove all its files, either in the Finder:

or in the terminal with

if [[ -d ~/Library/Application\ Support/obsidian/Cache/Cache_Data ]] ; then
    rm -rf ~/Library/Application\ Support/obsidian/Cache/Cache_Data/*
    echo "Something odd has happened"
  1. Restarting Obsidian and voila!

I hope this helps


Thanks @wealthychef . I don’t have that folder or file except in the roaming folder. I deleted that, but no change.

I’m sure you realized it, but the key piece would be the obsidian/Cache/Cache_Data part; the rest is highly mac-specific. The equivalent folder must exist somewhere on your machine! :slight_smile:

Cheers, that’s all I know for now. :slight_smile:

Yeah, that’s what’s weird. No such directory or file—anywhere. I have an obsidian roaming folder I deleted, but that didn’t help. Thanks for trying.

Try the %%APPDATA%% directory. How Obsidian stores data - Obsidian Help

C:\Users\rcook>cd %APPDATA%\Obsidian\

 Volume in drive C has no label.
 Volume Serial Number is 4607-95DA

 Directory of C:\Users\rcook\AppData\Roaming\obsidian

12/21/2022  09:52 AM    <DIR>          .
12/21/2022  09:47 AM    <DIR>          ..
12/21/2022  09:47 AM    <DIR>          blob_storage
12/21/2022  09:47 AM    <DIR>          Cache
12/21/2022  09:47 AM    <DIR>          Code Cache
12/21/2022  09:51 AM    <DIR>          databases
12/21/2022  09:47 AM    <DIR>          GPUCache
12/21/2022  09:47 AM                32 id
12/21/2022  09:51 AM    <DIR>          IndexedDB
12/21/2022  09:47 AM               389 Local State
12/21/2022  09:47 AM    <DIR>          Local Storage
12/21/2022  09:47 AM                 0 lockfile
12/21/2022  09:48 AM    <DIR>          Network
12/21/2022  09:51 AM               121 obsidian.json
12/21/2022  09:47 AM                 0 obsidian.log
12/21/2022  09:52 AM                97 Preferences
12/21/2022  09:52 AM            40,960 QuotaManager
12/21/2022  09:52 AM                 0 QuotaManager-journal
12/21/2022  09:51 AM    <DIR>          Session Storage
               8 File(s)         41,599 bytes
              11 Dir(s)  248,776,716,288 bytes free


Yes, that’s the one I deleted. Unfortunately, didn’t help. Frustrating.

1 Like

Have you tried removing the IndexedDB folder? If you use Obsidian Sync, you will have to connect it to the remote vault again. Alternatively you can delete just the -cache listings from within Obsidian and restart (in Developer tools).

If that doesn’t work, I’d get rid of that whole directory and reinstall. (Make backups of your vaults, etc)

1 Like