Stuck in loop on export full canvas to image (when app in full screen mode)

Steps to reproduce

  1. Create canvas
  2. Choose “export as image” and select “full canvas”
  3. Execute

Expected result

I expect an image to be created at the specified location

Actual result

Gets stuck at “rendering tiles.” Does not freeze, but stays in that state and clicking “stop” does nothing.


  • Operating system: Mac 13.2.1 (22D68)
  • Debug info:
    Obsidian version: v1.1.15
    Installer version: v1.1.9
    Operating system: Darwin Kernel Version 22.3.0: Mon Jan 30 20:38:43 PST 2023; root:xnu-8792.81.3~2/RELEASE_ARM64_T8112 22.3.0
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on


Additional information

On a MacBook Air M2 with 16gb of RAM.

1 Like

Ok. Does it happen with any canvas? Does it happen in the sandbox vault?

Yes, happens on every canvas tested, which includes a wide range of complexity and size. For this debug, I created a canvas in sandbox with two cards, three words of text each, and connected them. It happened with the last insider build, as well as today’s public release. I’ve restarted the app a few times and even did a machine restart, same result every time. I can’t remember if I exported on any version before that, so not sure if it is new to my system or just undiscovered.

One question: How long should the rendering take? I’ve let it go for a couple of minutes when I first experienced the problem. Since then, after around 30 seconds, I give up.

It should take a few seconds and you should see the progress bar moving. If you keep the console open while running the export, do you get any errors? (Cmd-opt-i → console tab)

The bar does move, but nothing else happens. I opened the console and it showed no output.

can you post a screen recording of this happening in the sandbox vault?

we are not sure what is going on.

I tried uploading a screen recording, but the forum is preventing the upload of video. Is there somewhere else to post it?

Anywhere you want and add a link here.

I don’t have a good place to host from. Is there another way to mail it or upload it directly to the team.

dropbox, icloud, gdrive, youtube

OK, I was able to upload a gif, so here you go:

Screen Recording 2023-02-24 at 4.18.42 PM-1 2

1 Like

ok. thanks

One more bit of information: I watched activity monitor during the export, and the total of Obsidian processes was under 1% for CPU utilization. That’s actually lower than usual (it moves around a lot in normal use, but regularly around 5%). Wondering if it’s just not executing vs getting hung up.

We don’t know what is happening, The app is not frozen. We are gonna wait for other reports on this bug.

Just want to give an update that there’s been no change in this bug with the latest release. I didn’t expect a fix, but thought you may want to know.

I just noticed in the gif your save location is Desktop - iCloud. Do you have iCloud Desktop and Documents sync enabled?

Don’t know if there’s any connection, but can you try a different location for saving - not in ~/Desktop or ~/Documents - if you haven’t yet?

Yes, I do have iCloud sync setup. I just tried to save to a folder outside of iCloud, and got the same behavior. I also tried to save in the root of my vault, and same issue.

It was worth a shot. Thanks for checking.


Not sure if anyone else has found a fix yet, but i just had this issue using a M2 Macbook Pro 14 with a pretty clittered canvas.

I spotted it was having issues closing the export window when in full screen mode, after leaving full screen mode it worked no with no issues and exported in around 30 seconds.

I hope this is helpful.

I have this exact issue on my mac.
MacBook Pro (16-inch, 2019)
macOSCatalina Version 10.15.17

Leaving for an extended period of time does nothing.

However, if I minimize the obsidian window, then maximize it again, the loading bar goes away. Then I see obsidian jump to random spots on the canvas (probably taking pictures?), then it successfully exports.

Sometimes the final image is broken when I do this workaround. I attached a broken exported image (pink parts are redacted for work).

In the image you can see the bottom right part is mismatched from the rest. (Looks like when sewing together screenshots, it took one in the wrong spot/placed it in the wrong spot).