Strange prefix to note names in index note

What I’m trying to do

A few index notes are displaying two periods and a forward slash at the front of the note names in the index. Screenshot attached:

Screen Shot 2023-03-21 at 10.30.30 AM

Things I have tried

Doesn’t interfere with my work in any way. Just curious why this happens.

You might have modified the path in your settings from shortest?

Thanks. No. It’s at “relative path to file.”

This is another index:

Screen Shot 2023-03-21 at 10.45.21 AM

Try shortest.

The ../ is usually a way to refer to the parent folder.

So if the other suggestion doesn’t pan out, an interesting question is whether the files in the parent folder are not unique since Obsidian feels the need to refer to the path of them?

Thanks again. Not that either. Restarted Obsidian. Unchanged.

Hmm. There are duplicate files? I have only three folders in my vault. Two for journal notes and one for new notes.

I think he means the files have gotten outside of your vault since making the index file. Also, try making the index file again.

I have two older vaults in my Obsidian trash folder. They were deleted long before the notes in these index notes were created. I checked visually too. No duplicates.

Screen Shot 2023-03-21 at 11.24.05 AM

So you had nested vaults. That’s where your problem lies.

Also, on another thread, CawlinTeffid already hinted:

Just the bare existence of vaults, even if in trash, causes the problem?

The trashed vaults contain no copies of the notes with these prefixes.

I don’t have nested vaults, so I have no way of knowing.
As for the deleted items, when I delete an image, it still shows in my markdown preview (probably until it is cached by Obsidian’s current session).

It’s best to delete the no-longer-needed items in your OS’s file manager.

Also, if you are using Markdown links, try going with Wikilinks.

I started out using markdown links. Don’t remember when I switched to wiki links.

I turned wiki links off. Links to those notes still contain the prefix. Restarted Obsidian. Still there.

I am using Wikilinks only (my native language is agglutinative so it makes more sense). Try Wikilinks with shortest path (my way).

I’ve been using wiki links for quite a while now. Set path to shortest. No change. Restarted Obsidian. No change.

I tried reentering one of the links. The new copy doesn’t have the prefix.

Not that many links in these notes. Maybe 40. I’ll just reenter them.

Thanks for your help.

Try learning your way with text editors like Notepad++ and Sublime Text and cut down on manual entering (copy and paste and remove offending parts).

After 25-30 years of MS Office, I have recently made the change to plain text myself.


Had to check out “agglutinative.” Now that I know what it is I’m familiar with it in Sanskrit.

I speak a language far older than Sanskrit, Sumerian or Old Egyptian (not to mention Hebrew).
Not many people know.

I love Vim, though I’m not a coder and need a lot of help getting it set up to my needs and likings. I’m using vim keybindings in Obsidian.

I got started with computing in the days of MS-DOS. Before windows. Everything command-driven. I had a lot of muscle memory for commands. Probably my favorite word processor ever was Wordstar.

I hated Windows at the begging and for as long as I used it. I’ve never like graphic interfaces for writing and editing.