Some images not loading

What I’m trying to do

Get my images to load as they are supposed to. It is not all images just some images. Out of one folder that contains notes and each note has at least one image on it only 2 are apparently corrupted/not showing up. It is a broken jpg symbol. Little white page with green on it and a tear through it. It shows the name of the file that should be there.

I need my images to show up and to understand what is happening so this doesn’t happen again. It is the same across Windows and Android systems. I have ObsidianSync.

Things I have tried

Looked it up online, but couldn’t find much on it.

According to Accepted file formats - Obsidian Help, .webp is an accepted format, and the few I checked work for me.

Can you show the Markdown source of how you are writing the link in your note just to double check …and if it’s not private, upload a copy here for others to have a look? That may help.

I think the markdown looks like this:


It is a copy and pasted image and worked for a while until recently.

Well, this is strange. I found the missing images while looking through a backup. The link seems to for some reason to have been pointing to a different vault.

I think it is possible that I started those files in the 1st vault, and then moved them into the current vault and for some reason, it still pointed to images in the 1st vault.

Great! Glad it’s sorted.

For next time, when someone asks about Markdown source text, they mean something like this - the link as it’s written in your note.


![markdown cat](cat.png)
1 Like

I tried to copy the markdown as it was. I don’t know how to use this forum. Thanks, I will try to figure that out next time.

No problem :smiley:

Have look at the forum use and formatting thread. :+1:t4:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.