Some Emojis are not rendered correctly on obsidian

Steps to reproduce

  1. Press win + . to open window 10 Emoji application
  2. Type keycap 0 and hit enter

Expected Result

  1. 0 will not rendered

Actual Result
0 will show in blue rectangle box


  • Operating System: windows 10 x64
  • Debug info:
    Obsidian version: v0.13.19
    Installer version: v0.13.19
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


  • Add more colourful emojis. There are some emojis like beach_holiday that looks very beautiful on other platform like on messenger. But here it is completly Black/White

Additional Information:

  • I have turned on safe mode but while using emoji shortcode, it also show some missing icons like ninja, militiary helmet, anatomical heart, asterick, keycap 0-9 (keycap 10 is rendering properly), beaver, beetle…


1 Like

Thanks, I believe this is an issue with the font used.

1 Like

The same,have you got the solution?

I have this same issue, in both editor and preview panes:



Output on Obsidian Publish:

This is on the Mac, and it shows that this emoji margin bug is also still in place:

I’m on the Obsidian 1.1.9 release and have tried with plugins/custom CSS all disabled.

@WhiteNoise I’ve also tried this with multiple fonts, the issue persists across all.

The emojis I’m using that break like this are the numbers emoji: :one: :four: :zero:
(They appear to break here in the Obsidian forum too, while writing a post; they show up fine upon publish)

The margin problem is a different one.

On windows, I don’t get this problem anymore because we use a different font. On mac, I am not sure. You can try to download and reinstall obsidian and see if this happens in the sandbox vault (default theme).