Smooth zoom in graph view when using mouse scroll

Use case or problem

LPS = lines per scroll

On my laptop, I am able to smoothly zoom into the graph using my touch pad, using either a two-digit scroll or spread-out gesture.

However, on a desktop, the ‘jump-in-zoom-level per scroll’ is at the mercy of the ‘lines per scroll’ (LPS) setting of the mouse. This makes it incredibly difficult to use the graph because it will either zoom way out, or zoom into 2-3 nodes.

Yes, I can reduce the LPS setting to 1 in the OS but then scrolling through webpages becomes tedious.

Proposed solution

Implement either feature or both for best results:

Inside the graph view, when you are scroll-zooming:

  1. A custom LPS setting that overrides OS’s LPS setting.
  2. Holding down the Shift key when scroll-zooming overrides OS setting and uses a LPS = 1 (or custom amount to simulate smooth zooming).

Current workaround (optional)

I have no current workarounds.

Related feature requests (optional)