Scrollbar appears in PDF export on mac

My original bug report was closed, here’s one with the requested information.
Happy holidays!

Steps to reproduce

[0. Fresh install of Obsidian 1.1.9 from the downloaded dmg]

  1. Create a document (in a new sandbox vault)
  2. Enter a long inline LaTeX formula:
$\ce{^232_90Th ->[\alpha] ^228_88Ra ->[\beta-] ^228_89Ac ->[\beta-] ^228_90Th}$
  1. Export to PDF (default settings)

Expected result

A PDF with just the formula

Actual result

A PDF with the formula and a picture of a horizontal scrollbar (see below)


  • Operating system: macOS 13.0.1
  • Debug info: SYSTEM INFO:
    Obsidian version: v1.1.9
    Installer version: v1.1.9
    Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:15:09 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T6000 22.1.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on


Additional information

The rendered width of this formula is less than half the available width. Yet in Reading View, a horizontal scrollbar also appears.

Screenshot of part of the PDF result:

Meta-information in the PDF file:
PDF Producer: Skia/PDF m106
Content creator: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) obsidian/1.1.9 Chrome/106.0.5249.199 Electron/21.3.3 Safari/537.36

Attachments: the Markdown file and the PDF output (80 Bytes) (9.5 KB)

What setting does macOS use for scroll bars? Set to Always?

I can’t reproduce. @eightning has a good suggestion.

1 Like

I have the system scrollbar settings at Automatically based on mouse or trackpad, and I have a mouse connected to the computer, so I always see scrollbars in documents that have some overflow.

When I change that to Always, the problem is also there. But at When scrolling, the problem disappears.

1 Like

I don’t know if that means this is a bug in Obsidian or one at the OS level, but it sounds as if you have a workable solution. Perhaps someone from the development team will reply further.

Do you know whether there’s any way to inspect the HTML that Obsidian sends to the PDF creator? There must be a scrollbar in there somewhere. If this were an OS problem, PDFs exported from other applications would also have scrollbar images, but I’ve never seen that happening.

Workaround for those who encounter the same problem: create and activate a CSS snippet with the following content:

@media print {
	::-webkit-scrollbar {
		display: none;
1 Like

will be fixed 1.1.14

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.