Reveal in Finder on MacOS not working

I click on “Reveal in Finder”, I expect to be directed to the file with Finder. But I was always directed to The obsidian iCloud folder: /Users/my_username/Library/Mobile Documents/iCloud~md~obsidian/Documents

I am not able to go deeper into the vault folder. I have two vaults in the iCloud, and click into either one of them, finder shows the same two folder again. Actually I can get this recursion many times:

  • I test on the sandbox it works fine (no bug).
  • I also create a new empty vault and put it into iCloud, the bug exists.
  • I create a new empty vault and put it outside of iCloud, no bug.

One possible reason for this bug might because iCloud has not fully synced. But sometime even if iCloud is fully synced, the bug persists. (I think even if iCloud is not fully synced, “reveal in finder” should also work to some extent, given obsidian considers iCloud as a cloud provider officially).

The bug report template needs to be filled in for bug reports. Thanks.

I wonder if this is a macOS Sonoma issue?

It’s the first I’ve seen mention of your issue, but there are a handful of Sonoma related iCloud issues.

Possibly a Sonoma issue indeed!
I am running Sonoma, have tried it as well, and ‘Reveal in Finder’ takes me to the iCloud directory containing all my vaults. Not to the directory containing the file I clicked on.

is your iclould set to keep all notes locally?

I just tried on two different macs (both running macOS 13.6 Ventura) with multiple vaults in iCloud Drive, and Reveal in Finder opens the Finder as expected to here:

If you’re willing, disable Optimize Mac Storage, let iCloud Drive download all of its contents onto your Mac, and then try again.

I just tried disabling ‘Optimise Mac Storage’ (btw, the settings screens look totally different on macOS Sonoma than the screenshots in your link).

Problem is, the switch toggles itself back on almost immediately. Only after three tries does it stay off.

And lo and behold, it seems to do the trick! Now ‘Reveal in Finder’ actually shows me the directory of the file I executed it on.

1 Like

Thanks for the reply. Unfortunately I have disabled this option for a long time, even before I use Obsidian. The problem persists.

I think you’re going to have to investigate what Sonoma has done to your iCloud Drive files.

Do you know if iCloud has finished downloading everything, per the above article?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.